summaryrefslogtreecommitdiff
path: root/server/configure.in
diff options
context:
space:
mode:
authordeva <deva>2010-10-06 11:44:36 +0000
committerdeva <deva>2010-10-06 11:44:36 +0000
commitac17efdb11e4f87df68306f1abe8a564257a1f90 (patch)
tree51de132fcf94db1819171e97788ea1717406a18d /server/configure.in
parent19bdce297f356efb8a75ea2c6a3d5e712ed98b63 (diff)
Check for inotify.
Diffstat (limited to 'server/configure.in')
-rw-r--r--server/configure.in11
1 files changed, 7 insertions, 4 deletions
diff --git a/server/configure.in b/server/configure.in
index 0a2bc89..c5cdc40 100644
--- a/server/configure.in
+++ b/server/configure.in
@@ -22,11 +22,14 @@ dnl ======================
inotify_support=no
AC_CHECK_HEADERS([sys/inotify.h],
[
- inotify_support=yes
- AC_CHECK_FUNCS(inotify_init1)
+ AC_CHECK_FUNCS(inotify_init1, inotify_support=yes
+)
])
-
-AM_CONDITIONAL(HAVE_INOTIFY, [test "$inotify_support" = "yes"])
+if test "$inotify_support" = "no"
+then
+ AC_MSG_ERROR([*** Inotify not found (needs at least 2.6.21 kernel)!])
+fi
+#AM_CONDITIONAL(HAVE_INOTIFY, [test "$inotify_support" = "yes"])
dnl ======================
dnl Compile with artefact support