summaryrefslogtreecommitdiff
path: root/server/configure.in
diff options
context:
space:
mode:
authordeva <deva>2010-10-06 11:38:54 +0000
committerdeva <deva>2010-10-06 11:38:54 +0000
commit19bdce297f356efb8a75ea2c6a3d5e712ed98b63 (patch)
tree38bfd33ed01b097726f153be28c7709331559159 /server/configure.in
parentdb022622b6f98eeebc600e94829fb586583d61c7 (diff)
Check for inotify.
Diffstat (limited to 'server/configure.in')
-rw-r--r--server/configure.in15
1 files changed, 14 insertions, 1 deletions
diff --git a/server/configure.in b/server/configure.in
index 460b463..0a2bc89 100644
--- a/server/configure.in
+++ b/server/configure.in
@@ -14,7 +14,19 @@ if test x$with_debug == xyes; then
AC_MSG_WARN([*** Building with debug support!])
AC_DEFINE_UNQUOTED(WITH_DEBUG, , [The project is configured to use debug output])
CXXFLAGS="$CXXFLAGS -D_FORTIFY_SOURCE=2 -fstack-protector -Wall -Werror -g -O0"
-fi
+fi
+
+dnl ======================
+dnl Check for inotify (old and new)
+dnl ======================
+inotify_support=no
+AC_CHECK_HEADERS([sys/inotify.h],
+[
+ inotify_support=yes
+ AC_CHECK_FUNCS(inotify_init1)
+])
+
+AM_CONDITIONAL(HAVE_INOTIFY, [test "$inotify_support" = "yes"])
dnl ======================
dnl Compile with artefact support
@@ -149,6 +161,7 @@ dnl Check for libmicrohttpd
dnl ======================
PKG_CHECK_MODULES(HTTPD, libmicrohttpd >= 0.4.4)
+
dnl ======================
dnl Check for eXpat library
dnl ======================