summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2020-06-06 20:42:17 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2020-06-06 20:42:17 +0200
commit5f95718e7ebe4dec017055500793b928d8946d8e (patch)
tree4f85539d23b2ffb0e35931e1291a107782870ac9 /test/Makefile.am
parent540f839cb5868dac3eb409f509b85995826cf559 (diff)
Port existing (in-file embedded) unit-tests to new framework.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am37
1 files changed, 36 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 34b750d..3e962ee 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,7 +1,7 @@
# Rules for the test code (use `make check` to execute)
if ENABLE_TESTS
-TESTS = logintest
+TESTS = logintest xmlencodetest connectionhandlertest nodetreetest
EXTRA_DIST = \
dgunit.h \
@@ -17,4 +17,39 @@ logintest_SOURCES = \
logintest.cc \
dgtest.cc
+xmlencodetest_CXXFLAGS = -DOUTPUT=\"xmlencodetest\" \
+ $(DEBUG_FLAGS) \
+ -I$(top_srcdir)/src
+xmlencodetest_LDFLAGS =
+xmlencodetest_SOURCES = \
+ $(top_srcdir)/src/xml_encode_decode.cc \
+ xmlencodetest.cc \
+ dgtest.cc
+
+connectionhandlertest_CXXFLAGS = -DOUTPUT=\"connectionhandlertest\" \
+ $(DEBUG_FLAGS) \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/hugin
+connectionhandlertest_LDFLAGS =
+connectionhandlertest_SOURCES = \
+ $(top_srcdir)/hugin/hugin.c \
+ $(top_srcdir)/src/connectionhandler.cc \
+ connectionhandlertest.cc \
+ dgtest.cc
+
+nodetreetest_CXXFLAGS = -DOUTPUT=\"nodetreetest\" \
+ $(DEBUG_FLAGS) \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/hugin \
+ $(EXPAT_CFLAGS)
+nodetreetest_LDFLAGS = $(EXPAT_LIBS)
+nodetreetest_SOURCES = \
+ $(top_srcdir)/hugin/hugin.c \
+ $(top_srcdir)/src/nodetree.cc \
+ $(top_srcdir)/src/xmlparser.cc \
+ $(top_srcdir)/src/saxparser.cc \
+ $(top_srcdir)/src/xml_encode_decode.cc \
+ nodetreetest.cc \
+ dgtest.cc
+
endif