summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2020-06-06 19:44:36 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2020-06-06 19:44:36 +0200
commit540f839cb5868dac3eb409f509b85995826cf559 (patch)
tree42d2b9414edb748ad5d32efffcfeced18bf0b0b4 /test/Makefile.am
parentfa5985ed620c3cd4c7b9712b6b80a2e2c1a8ba31 (diff)
Add unit-test framework.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am25
1 files changed, 16 insertions, 9 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 8cf4ce5..34b750d 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,13 +1,20 @@
# Rules for the test code (use `make check` to execute)
-TESTS = proto
+if ENABLE_TESTS
+
+TESTS = logintest
+
+EXTRA_DIST = \
+ dgunit.h \
+ scopedfile.h
check_PROGRAMS = $(TESTS)
-proto_CXXFLAGS = -DOUTPUT=\"proto\" $(CPPUNIT_CFLAGS) \
- -I$(top_srcdir)/src -I$(top_srcdir)/hugin -DDISABLE_HUGIN
-proto_CFLAGS = -DDISABLE_HUGIN
-proto_LDFLAGS = $(CPPUNIT_LIBS)
-proto_SOURCES = \
- $(top_srcdir)/hugin/hugin.c \
- test.cc \
- proto.cc
+logintest_CXXFLAGS = -DOUTPUT=\"logintest\" \
+ $(DEBUG_FLAGS) \
+ -I$(top_srcdir)/src
+logintest_LDFLAGS =
+logintest_SOURCES = \
+ logintest.cc \
+ dgtest.cc
+
+endif