summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2012-03-30 11:37:58 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2012-03-30 11:37:58 +0200
commit39e9508260335eb5cd817e9899a11cb011efdbed (patch)
treefe3b9c6dde89be8d77a324e802e67de5d1b32b88 /src/Makefile.am
parent91dad205b83319e00ea8060ca5a63de07b126c8f (diff)
Add observe protocol and connection handler.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8c2cc25..781422d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -7,25 +7,29 @@ muniad_LDADD = $(LIBWEBSOCKETS_LIBS) $(EXPAT_LIBS)
muniad_CXXFLAGS = $(LIBWEBSOCKETS_CFLAGS) $(EXPAT_CFLAGS) -I/usr/local/include
muniad_SOURCES = \
- debug.cc \
muniad.cc \
+ connectionhandler.cc \
+ debug.cc \
log.cc \
http.cc \
- msgparser.cc \
+ messageparser.cc \
saxparser.cc \
task.cc \
task_proto.cc \
+ observe_proto.cc \
xml_encode_decode.cc \
xmlparser.cc
EXTRA_DIST = \
debug.h \
+ connectionhandler.h \
log.h \
http.h \
- msgparser.h \
+ messageparser.h \
saxparser.h \
task.h \
task_proto.h \
+ observe_proto.h \
xml_encode_decode.h \
xmlparser.h