summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2013-11-20 12:57:17 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2013-11-20 12:57:17 +0100
commit60f60cc76e43197a0825ffac9aff0b7007a94175 (patch)
tree9a35ef295e84dc8555eb7e361062d0aedeae8edd /src/Makefile.am
parent6a9ad0e4234b47982b82b30e8774dcc311f43cd2 (diff)
Framework API now complete in its first iteration. So far with support for raw, opus and amrwb.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 594b257..15a201f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -5,10 +5,23 @@ liblrtp_la_LIBADD = $(SRTP_LIBS)
liblrtp_la_CXXFLAGS = $(SRTP_CXXFLAGS)
liblrtp_la_SOURCES = \
- lrtp.cc
+ lrtp.cc \
+ rtp.cc \
+ srtp.cc \
+ rtp_profile_amrwb.cc \
+ rtp_profile_opus.cc \
+ rtp_profile_raw.cc \
+ asc2bin.cc
include_HEADERS = \
- lrtp.h
+ lrtp.h \
+ lrtp_profiles.h
-EXTRA_DIST =
+EXTRA_DIST = \
+ rtp_profile_amrwb.h \
+ rtp_profile_opus.h \
+ rtp_profile_raw.h \
+ rtp.h \
+ srtp.h \
+ asc2bin.h