summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2374032..48ef55d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,6 +56,16 @@ dnl ======================
PKG_CHECK_MODULES(OPUS, opus >= 1.0.2)
dnl ======================
+dnl Check for libpulse
+dnl ======================
+AC_ARG_WITH(pulse, [ --with-pulse Build with pulse support])
+if test x$with_pulse == xyes; then
+ PKG_CHECK_MODULES(PULSE, pulse >= 1.0.0)
+ AC_MSG_WARN([*** Building with libpulse support!])
+ CXXFLAGS="$CXXFLAGS -DWITH_PULSE"
+fi
+
+dnl ======================
dnl Check for Jpeg library
dnl ======================
AC_CHECK_HEADER(jpeglib.h, , AC_MSG_ERROR([*** libJpeg not found!]))