summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2014-09-18 19:20:10 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2014-09-18 19:20:10 +0200
commitc9cb81aac55962bd6da36e0e4e23eb9061901a80 (patch)
treece982e70c6bfe2fe55b52b4fe2409164423a8e0e /src/Makefile.am
Skeleton project.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..4804101
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,38 @@
+bin_PROGRAMS = simplertp
+
+simplertp_LDADD = $(QT_LIBS) $(AO_LIBS) \
+ $(shell ../tools/MocList o ) qrc_simplertp.o
+
+simplertp_CXXFLAGS = $(QT_CFLAGS) $(AO_CFLAGS)
+AM_CXXFLAGS = $(QT_CFLAGS)
+
+simplertp_SOURCES = \
+ simplertp.cc
+
+EXTRA_DIST = \
+ simplertp.qrc
+
+simplertp_MOC = $(shell ../tools/MocList cc )
+
+BUILT_SOURCES = $(simplertp_MOC) qrc_simplertp.cc
+
+CLEANFILES = $(BUILT_SOURCES)
+
+qrc_%.cc: %.qrc
+ rcc $< > $@
+
+%.moc.cc: %.h
+ $(QT_MOC) -o $@ $<
+
+#
+# ui files not used in this project...
+#%.h: %.ui
+# $(QT_UIC) -o $@ $<
+#
+#%.cc: %.ui
+# $(QT_UIC) -o $@ -impl $*.h $<
+
+# command for creating .res file from .rc on Win32
+%.res: %.rc
+ rc $<
+