summaryrefslogtreecommitdiff
path: root/server/src/macrotool/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'server/src/macrotool/Makefile.am')
-rw-r--r--server/src/macrotool/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/server/src/macrotool/Makefile.am b/server/src/macrotool/Makefile.am
new file mode 100644
index 0000000..e6fdc94
--- /dev/null
+++ b/server/src/macrotool/Makefile.am
@@ -0,0 +1,50 @@
+
+bin_PROGRAMS = macrotool
+
+macrotool_LDADD = $(LD_EFENCE) $(PQXX_LIBS) $(CONFIG_LIBS) \
+ $(LUA_LIBS) $(PTHREAD_LIBS) $(EXPAT_LIBS)
+
+macrotool_CXXFLAGS = -I.. $(PQXX_CXXFLAGS) $(CONFIG_CXXFLAGS) \
+ $(LUA_CXXFLAGS) $(PTHREAD_CFLAGS) $(EXPAT_CFLAGS)
+
+macrotool_SOURCES = \
+ macrotool.cc \
+ macrotool_dump.cc \
+ macrotool_fieldnames.cc \
+ macrotool_filehandler.cc \
+ macrotool_util.cc \
+ ../debug.cc \
+ ../configuration.cc \
+ ../configurationparser.cc \
+ ../database.cc \
+ ../entitylist.cc \
+ ../exception.cc \
+ ../inotify.cc \
+ ../log.cc \
+ ../macroheaderparser.cc \
+ ../macrolist.cc \
+ ../macroparser.cc \
+ ../mutex.cc \
+ ../pracrodao.cc \
+ ../pracrodaopgsql.cc \
+ ../pracrodaotest.cc \
+ ../saxparser.cc \
+ ../templateparser.cc \
+ ../versionstr.cc
+
+EXTRA_DIST = \
+ macrotool_dump.h \
+ macrotool_fieldnames.h \
+ macrotool_filehandler.h \
+ macrotool_util.h
+
+################
+# Test Section #
+################
+
+#TEST_SOURCE_DEPS = ${macrotool_SOURCES} ${EXTRA_DIST}
+#TEST_SCRIPT_DIR = $(top_srcdir)/../../tools
+
+#include ${TEST_SCRIPT_DIR}/Makefile.am.test
+
+#include Makefile.am.test \ No newline at end of file