summaryrefslogtreecommitdiff
path: root/server/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'server/configure.in')
-rw-r--r--server/configure.in9
1 files changed, 5 insertions, 4 deletions
diff --git a/server/configure.in b/server/configure.in
index e65ac33..3b6d593 100644
--- a/server/configure.in
+++ b/server/configure.in
@@ -93,11 +93,12 @@ if test x$with_db == xno; then
AC_DEFINE_UNQUOTED(WITHOUT_DB, , [The project is configured not to use the db])
else
dnl ======================
- dnl Check for libpqxx
+ dnl Check for libpg
dnl ======================
- PKG_CHECK_MODULES(PQXX, libpqxx >= 4.0,
- [AC_DEFINE_UNQUOTED([USE_NEW_PQXX], [1], [Use new pqx api])],
- [PKG_CHECK_MODULES(PQXX, libpqxx >= 2.6.8)] )
+ PQ_CFLAGS="-I$(pg_config --includedir)"
+ AC_SUBST(PQ_CFLAGS)
+ PQ_LIBS="-L$(pg_config --libdir) -lpq"
+ AC_SUBST(PQ_LIBS)
fi
dnl ======================