summaryrefslogtreecommitdiff
path: root/server/src/Makefile.am
diff options
context:
space:
mode:
authordeva <deva>2009-02-11 07:14:22 +0000
committerdeva <deva>2009-02-11 07:14:22 +0000
commit4df8884f155f7558c07949426c248e066df7936f (patch)
tree61030bad443e366b8fb0e097200693ab56df01c4 /server/src/Makefile.am
parentbbe2b5f899a9c1bd7c99181f8702ec03c60f3028 (diff)
Added QueryHandler for both Pentominos and Pracro. Added source string to all values, and use these to set the prefill value in the macros.
Diffstat (limited to 'server/src/Makefile.am')
-rw-r--r--server/src/Makefile.am15
1 files changed, 11 insertions, 4 deletions
diff --git a/server/src/Makefile.am b/server/src/Makefile.am
index a4f2fd7..086905a 100644
--- a/server/src/Makefile.am
+++ b/server/src/Makefile.am
@@ -13,7 +13,8 @@ pracrod_SOURCES = \
configurationparser.cc \
debug.cc \
exception.cc \
- queryhandler.cc \
+ queryhandlerpentominos.cc \
+ queryhandlerpracro.cc \
queryparser.cc \
journal_commit.cc \
log.cc \
@@ -40,6 +41,8 @@ EXTRA_DIST = \
debug.h \
exception.h \
queryhandler.h \
+ queryhandlerpentominos.h \
+ queryhandlerpracro.h \
queryparser.h \
journal_commit.h \
log.h \
@@ -59,7 +62,8 @@ EXTRA_DIST = \
TESTFILES = \
test_formattools \
- test_queryhandler \
+ test_queryhandlerpentominos \
+ test_queryhandlerpracro \
test_queryparser \
test_luaquerymapper \
test_templateparser \
@@ -84,8 +88,11 @@ test_mltokenizer: mltokenizer.cc
test_formattools: formattools.cc luaformatmapper.cc luaformatmapperutils.cc mltokenizer.cc
@../../tools/test formattools.cc luaformatmapper.cc mltokenizer.cc luaformatmapperutils.cc exception.cc log.cc $(LUA_LIBS)
-test_queryhandler: queryhandler.cc
- @../../tools/test queryhandler.cc tcpsocket.cc exception.cc log.cc
+test_queryhandlerpentominos: queryhandlerpentominos.cc
+ @../../tools/test queryhandlerpentominos.cc tcpsocket.cc exception.cc log.cc
+
+test_queryhandlerpracro: queryhandlerpracro.cc
+ @../../tools/test queryhandlerpracro.cc tcpsocket.cc exception.cc log.cc
test_queryparser: queryparser.cc
@../../tools/test queryparser.cc queryhandler.cc tcpsocket.cc exception.cc log.cc saxparser.cc -lexpat