summaryrefslogtreecommitdiff
path: root/server/configure.in
diff options
context:
space:
mode:
authordeva <deva>2008-07-29 12:52:50 +0000
committerdeva <deva>2008-07-29 12:52:50 +0000
commite388de9cf524977c36b523e31ad9d75816207ff5 (patch)
tree4845b6396c9ca071a11345ca5ce87077542d48d3 /server/configure.in
parent42512d40ef93f0f85d107a7dc6d58973f93a1d95 (diff)
Added configure option to remove pentominos support.
Diffstat (limited to 'server/configure.in')
-rw-r--r--server/configure.in17
1 files changed, 16 insertions, 1 deletions
diff --git a/server/configure.in b/server/configure.in
index 624df8e..79a14e1 100644
--- a/server/configure.in
+++ b/server/configure.in
@@ -6,12 +6,27 @@ AM_INIT_AUTOMAKE( pracrod, 0.0.1 )
dnl ======================
dnl Compile with debug options
dnl ======================
-AC_ARG_WITH(debug, [ --with-debug build with debug support])
+AC_ARG_WITH(debug,
+ [ --with-debug build with debug support (default=no)],
+ [with_debug=yes],
+ [with_debug=no])
if test x$with_debug == xyes; then
AC_MSG_WARN([*** Building with debug support!])
CXXFLAGS="$CXXFLAGS -D_FORTIFY_SOURCE=2 -fstack-protector -Wall -Werror -g -O0"
fi
+dnl ======================
+dnl Compile without pentominos support
+dnl ======================
+AC_ARG_WITH(pentominos,
+ [ --with-pentominos build without pentominos support (default=yes)],
+ [],
+ [with_pentominos=yes])
+if test x$with_pentominos == xno; then
+ AC_MSG_WARN([*** Building without pentominos support!])
+ CXXFLAGS="$CXXFLAGS -DWITHOUT_PENTOMINOS"
+fi
+
AC_PROG_CXX
AC_PROG_LIBTOOL