summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3716732..41440bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,6 +9,7 @@ AM_SILENT_RULES([yes])
dnl ======================
dnl Compile with debug options
dnl ======================
+HUGIN_PARM="-DDISABLE_HUGIN"
AC_ARG_WITH(debug,
[ --with-debug build with debug support (default=no)],
[],
@@ -17,7 +18,9 @@ if test x$with_debug == xyes; then
AC_MSG_WARN([*** Building with debug support!])
AC_DEFINE_UNQUOTED(WITH_DEBUG, , [The project is configured to use debug output])
CXXFLAGS="$CXXFLAGS -fstack-protector -Wall -Werror -g -O0"
+ HUGIN_PARM=""
fi
+CXXFLAGS="$CXXFLAGS $HUGIN_PARM"
dnl ======================
dnl Init pkg-config