summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 4747405..3137788 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,12 +32,13 @@ dnl Check for getopt
dnl ======================
AC_HAVE_HEADERS(getopt.h)
-#AC_ARG_WITH(test, [ --with-test Build unit tests])
-#if test x$with_test == xyes; then
-# AC_MSG_WARN([*** Building unittests!])
-# AM_PATH_CPPUNIT(1.9.6)
-# AC_OUTPUT(test/Makefile)
-#fi
+dnl ======================
+dnl Compile unit tests
+dnl ======================
+AC_ARG_WITH([test],
+ AS_HELP_STRING([--with-test], [Build unit tests]))
+
+AM_CONDITIONAL([ENABLE_TESTS], [test "x$with_test" = "xyes"])
dnl ======================
dnl Check for eXpat library
@@ -72,5 +73,6 @@ PKG_CHECK_MODULES(LIBWEBSOCKETS, libwebsockets >= 2.1)
AC_OUTPUT(
Makefile
src/Makefile
+ test/Makefile
tools/Makefile)