summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2013-12-06 13:21:35 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2013-12-06 13:21:35 +0100
commit977ed85235665be89f1f14259d83f6fb0bf1c437 (patch)
tree759b42913065258e21df3e82fcad555aa50fa7c4 /test/Makefile.am
parent81d5962b88a59291d3296a84ab7bdca537cf63cf (diff)
CppUnit introduced.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..8cf4ce5
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,13 @@
+# Rules for the test code (use `make check` to execute)
+TESTS = proto
+
+check_PROGRAMS = $(TESTS)
+
+proto_CXXFLAGS = -DOUTPUT=\"proto\" $(CPPUNIT_CFLAGS) \
+ -I$(top_srcdir)/src -I$(top_srcdir)/hugin -DDISABLE_HUGIN
+proto_CFLAGS = -DDISABLE_HUGIN
+proto_LDFLAGS = $(CPPUNIT_LIBS)
+proto_SOURCES = \
+ $(top_srcdir)/hugin/hugin.c \
+ test.cc \
+ proto.cc