summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2013-12-06 11:52:46 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2013-12-06 11:52:46 +0100
commitcc52d150eb5b823e1a0f50b27a1611df982ac568 (patch)
treed5689f899deab64862600fc5029ee023cb5286c6 /configure.in
parentcb589f7cb810172c66f1a07b9b19c8d2a17a22ca (diff)
Modernise autoconf.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in70
1 files changed, 0 insertions, 70 deletions
diff --git a/configure.in b/configure.in
deleted file mode 100644
index d4f48f0..0000000
--- a/configure.in
+++ /dev/null
@@ -1,70 +0,0 @@
-# Filename: configure.in
-
-AC_INIT(src/muniad.cc)
-
-VERSION="0.0.1"
-AM_INIT_AUTOMAKE( munia, $VERSION )
-
-dnl ======================
-dnl Compile with debug options
-dnl ======================
-AC_ARG_WITH(debug,
- [ --with-debug build with debug support (default=no)],
- [],
- [with_debug=no])
-if test x$with_debug == xyes; then
- AC_MSG_WARN([*** Building with debug support!])
- AC_DEFINE_UNQUOTED(WITH_DEBUG, , [The project is configured to use debug output])
- CXXFLAGS="$CXXFLAGS -D_FORTIFY_SOURCE=2 -fstack-protector -Wall -Werror -g -O0"
-fi
-
-dnl ======================
-dnl Init pkg-config
-dnl ======================
-PKG_PROG_PKG_CONFIG(0.23)
-
-AC_PROG_CXX
-
-AM_CONFIG_HEADER(config.h)
-AC_STDC_HEADERS
-
-dnl ======================
-dnl Check for getopt
-dnl ======================
-AC_HAVE_HEADERS(getopt.h)
-
-dnl ======================
-dnl Check for eXpat library
-dnl ======================
-tmp_CXXFLAGS="$CXXFLAGS"
-tmp_CPPFLAGS="$CPPFLAGS"
-tmp_CFLAGS="$CFLAGS"
-tmp_LDFLAGS="$LDFLAGS"
-tmp_LIBS="$LIBS"
-CXXFLAGS=""
-CPPFLAGS=""
-CFLAGS=""
-LDFLAGS=""
-LIBS=""
-AC_CHECK_HEADER(expat.h, , AC_MSG_ERROR([*** eXpat header file not found!]))
-AC_CHECK_LIB(expat, XML_ParserCreate, , AC_MSG_ERROR([*** eXpat library not found!]))
-EXPAT_CFLAGS="$CXXFLAGS $CPPFLAGS $CFLAGS"
-EXPAT_LIBS="$LDFLAGS $LIBS"
-CXXFLAGS="$tmp_CXXFLAGS"
-CPPFLAGS="$tmp_CPPFLAGS"
-CFLAGS="$tmp_CFLAGS"
-LDFLAGS="$tmp_LDFLAGS"
-LIBS="$tmp_LIBS"
-AC_SUBST(EXPAT_CFLAGS)
-AC_SUBST(EXPAT_LIBS)
-
-dnl ======================
-dnl Check for libwebsockets library
-dnl ======================
-PKG_CHECK_MODULES(LIBWEBSOCKETS, libwebsockets >= 1.23)
-
-AC_OUTPUT(
- Makefile
- src/Makefile
- tools/Makefile)
-