summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2013-12-06 13:21:35 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2013-12-06 13:21:35 +0100
commit977ed85235665be89f1f14259d83f6fb0bf1c437 (patch)
tree759b42913065258e21df3e82fcad555aa50fa7c4 /configure.ac
parent81d5962b88a59291d3296a84ab7bdca537cf63cf (diff)
CppUnit introduced.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 10 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e115d4f..c50f27e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,9 +12,9 @@ AC_ARG_WITH(debug,
[],
[with_debug=no])
if test x$with_debug == xyes; then
- AC_MSG_WARN([*** Building with debug support!])
- AC_DEFINE_UNQUOTED(WITH_DEBUG, , [The project is configured to use debug output])
- CXXFLAGS="$CXXFLAGS -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector -Wall -Werror -g -O0"
+ AC_MSG_WARN([*** Building with debug support!])
+ AC_DEFINE_UNQUOTED(WITH_DEBUG, , [The project is configured to use debug output])
+ CXXFLAGS="$CXXFLAGS -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector -Wall -Werror -g -O0"
fi
dnl ======================
@@ -32,6 +32,13 @@ dnl Check for getopt
dnl ======================
AC_HAVE_HEADERS(getopt.h)
+AC_ARG_WITH(test, [ --with-test Build unit tests])
+if test x$with_test == xyes; then
+ AC_MSG_WARN([*** Building unittests!])
+ AM_PATH_CPPUNIT(1.9.6)
+ AC_OUTPUT(test/Makefile)
+fi
+
dnl ======================
dnl Check for eXpat library
dnl ======================