summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ed812d5..fa10241 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,12 @@
-bin_PROGRAMS = miav miavd
+bin_PROGRAMS =
+
+if WITH_GUI
+bin_PROGRAMS += miav
+endif
+
+if WITH_SERVER
+bin_PROGRAMS += miavd
+endif
# This is needed for XXXX.moc.o compilation
AM_CXXFLAGS = $(QT_CFLAGS)
@@ -78,6 +86,8 @@ EXTRA_DIST = \
aboutwindow.h \
audio_encoder.h \
camera.h \
+ config.h \
+ cprlisten.h \
cprquerydialog.h \
daemon.h \
debug.h \
@@ -105,9 +115,8 @@ EXTRA_DIST = \
libmplex_wrapper.h \
mainwindow.h \
messagebox.h \
- miav.h \
- miav_daemon.h \
miav_config.h \
+ miav_daemon.h \
mov_encoder.h \
mov_encoder_thread.h \
mov_encoder_writer.h \
@@ -119,9 +128,9 @@ EXTRA_DIST = \
package.h \
player.h \
queue.h \
+ semaphore.h \
server.h \
server_status.h \
- semaphore.h \
socket.h \
thread.h \
threadsafe_queue.h \