summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authordeva <deva>2005-03-27 18:16:31 +0000
committerdeva <deva>2005-03-27 18:16:31 +0000
commit088296e7e6e5fd6c837ae08b826c8b56baa0eb4b (patch)
tree58c119a46aab42d2bb3b7feb43d16a40d7e67dd1 /src/Makefile.am
parent3392d8657f6f6ebc341709d5f500040ed4f559ef (diff)
Fixed pixmap path and dist taget in Makefiles.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am30
1 files changed, 28 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9d574e4..24c6972 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,8 +2,8 @@
## TODO: Move ffmpeg, libxml and libsdl into configure.in
AM_CXXFLAGS := $(CXXFLAGS) $(EXTRA_CXXFLAGS) -I../include $(QT_CXXFLAGS) \
+ -DPIXMAPS=\"$(datadir)/pixmaps\" \
-I/usr/include/ffmpeg
-# -I/usr/include/SDL
bin_PROGRAMS = miav
@@ -30,9 +30,35 @@ miav_SOURCES = $(shell if [ $QT_CXXFLAGS ] ; then ../tools/MocList cc; fi ) \
server.cc \
error.cc
+EXTRA_DIST = \
+ miav.conf \
+ cprquery.conf \
+ aboutwindow.h \
+ camera.h \
+ cprquerydialog.h \
+ decoder.h \
+ dvframe.h \
+ encoder.h \
+ error.h \
+ ffframe.h \
+ img_encoder.h \
+ mainwindow.h \
+ messagebox.h \
+ miav.h \
+ miav_config.h \
+ mov_encoder.h \
+ network.h \
+ package.h \
+ player.h \
+ queue.h \
+ server.h \
+ socket.h \
+ thread.h \
+ util.h \
+ videowidget.h
+
miav_LDADD := $(shell if [ $QT_CXXFLAGS ] ; then ../tools/MocList o; fi ) \
-lavcodec -lavformat
-# -lSDL
miav_MOC = $(shell if [ $QT_CXXFLAGS ] ; then ../tools/MocList cc; fi )