summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 00dc707..f5dfca8 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,7 +1,11 @@
-TESTS = jpeg amrwb opus init rtp srtp raw l16 asc2bin framelist
+TESTS = instance jpeg amrwb opus init rtp srtp raw l16 asc2bin framelist
check_PROGRAMS = $(TESTS)
+instance_CXXFLAGS = $(CPPUNIT_CFLAGS) -DOUTPUT=\"instance\" -I../src
+instance_LDFLAGS = $(CPPUNIT_LIBS) -L../src/.libs/ -llrtp
+instance_SOURCES = test.cc test_instance.cc
+
jpeg_CXXFLAGS = $(CPPUNIT_CFLAGS) -DOUTPUT=\"jpeg\" -I../src
jpeg_LDFLAGS = $(CPPUNIT_LIBS) -L../src/.libs/ -llrtp
jpeg_SOURCES = test.cc test_jpeg.cc