summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2014-05-30 10:54:44 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2014-05-30 10:54:44 +0200
commit44fb055cf47a3a54cce0d746af23955753284422 (patch)
tree63c91a02937b094fb122caa59399e7f1e95a8ae5 /test/Makefile.am
parent7fc1b8f300b2ce2e7f8bd573f02b8650213c2be9 (diff)
Modify unit tests to match API change.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 00dc707..f5dfca8 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,7 +1,11 @@
-TESTS = jpeg amrwb opus init rtp srtp raw l16 asc2bin framelist
+TESTS = instance jpeg amrwb opus init rtp srtp raw l16 asc2bin framelist
check_PROGRAMS = $(TESTS)
+instance_CXXFLAGS = $(CPPUNIT_CFLAGS) -DOUTPUT=\"instance\" -I../src
+instance_LDFLAGS = $(CPPUNIT_LIBS) -L../src/.libs/ -llrtp
+instance_SOURCES = test.cc test_instance.cc
+
jpeg_CXXFLAGS = $(CPPUNIT_CFLAGS) -DOUTPUT=\"jpeg\" -I../src
jpeg_LDFLAGS = $(CPPUNIT_LIBS) -L../src/.libs/ -llrtp
jpeg_SOURCES = test.cc test_jpeg.cc