summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2014-01-06 08:07:56 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2014-01-06 08:07:56 +0100
commit0f900a2b4d7707dddeddadd62ac5a109aed93e7e (patch)
treec7b125951de8d4e6ee045449d03b3772e84f8bac /test/Makefile.am
parent06cd551da9405a220b170ffaf77d6554cbace69d (diff)
Fix round robin frame selector. Add l16 and jpeg profiles. Add timestamp to lrtp_enqueue_frame.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index b735c3c..00dc707 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,7 +1,11 @@
-TESTS = amrwb opus init rtp srtp raw asc2bin
+TESTS = jpeg amrwb opus init rtp srtp raw l16 asc2bin framelist
check_PROGRAMS = $(TESTS)
+jpeg_CXXFLAGS = $(CPPUNIT_CFLAGS) -DOUTPUT=\"jpeg\" -I../src
+jpeg_LDFLAGS = $(CPPUNIT_LIBS) -L../src/.libs/ -llrtp
+jpeg_SOURCES = test.cc test_jpeg.cc
+
amrwb_CXXFLAGS = $(CPPUNIT_CFLAGS) -DOUTPUT=\"amrwb\" -I../src
amrwb_LDFLAGS = $(CPPUNIT_LIBS) -L../src/.libs/ -llrtp
amrwb_SOURCES = test.cc test_amrwb.cc
@@ -26,9 +30,17 @@ raw_CXXFLAGS = $(CPPUNIT_CFLAGS) -DOUTPUT=\"raw\" -I../src
raw_LDFLAGS = $(CPPUNIT_LIBS) -L../src/.libs/ -llrtp
raw_SOURCES = test.cc test_raw.cc
+l16_CXXFLAGS = $(CPPUNIT_CFLAGS) -DOUTPUT=\"l16\" -I../src
+l16_LDFLAGS = $(CPPUNIT_LIBS) -L../src/.libs/ -llrtp
+l16_SOURCES = test.cc test_l16.cc
+
asc2bin_CXXFLAGS = $(CPPUNIT_CFLAGS) -DOUTPUT=\"asc2bin\" -I../src
asc2bin_LDFLAGS = $(CPPUNIT_LIBS)
asc2bin_SOURCES = test.cc test_asc2bin.cc
+framelist_CXXFLAGS = $(CPPUNIT_CFLAGS) -DOUTPUT=\"framelist\" -I../src
+framelist_LDFLAGS = $(CPPUNIT_LIBS) -L../src/.libs/ -llrtp
+framelist_SOURCES = test.cc test_framelist.cc
+
clean-local:
-rm -f result_*.xml