summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2013-08-28 10:11:13 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2013-08-28 10:11:13 +0200
commit85c89b8ce37ac26d060d7ed09cc2406f92b18e29 (patch)
treef512f87b97d755d09c808dae11ba5462413f3c34 /configure.in
parentebb0fb3024590bc53acd9a2338dbc02f8bc92c94 (diff)
Initial project skeleton.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in73
1 files changed, 73 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..ddf76b9
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,73 @@
+# Filename: configure.in
+
+AC_INIT([lrtp], [1.0.0])
+AC_CONFIG_SRCDIR([src/lrtp.cc])
+AM_INIT_AUTOMAKE
+
+dnl ======================
+dnl Compile with debug options
+dnl ======================
+AC_ARG_WITH(debug,
+ [ --with-debug build with debug support (default=no)],
+ [],
+ [with_debug=no])
+if test x$with_debug == xyes; then
+ AC_MSG_WARN([*** Building with debug support!])
+ AC_DEFINE_UNQUOTED(WITH_DEBUG, , [The project is configured to use debug output])
+ CXXFLAGS="$CXXFLAGS -D_FORTIFY_SOURCE=2 -fstack-protector -Wall -Werror -g -O0"
+fi
+
+dnl ======================
+dnl Init pkg-config
+dnl ======================
+PKG_PROG_PKG_CONFIG(0.23)
+
+dnl ======================
+dnl Compile with encryption
+dnl ======================
+AC_ARG_WITH(crypto,
+ [ --with-crypto build with crypto support (default=yes)],
+ [],
+ [with_crypto=yes])
+if test x$with_crypto == xyes; then
+ AC_MSG_WARN([*** Building with crypto support!])
+ CXXFLAGS="$CXXFLAGS -DUSE_CRYPTO"
+fi
+
+dnl ======================
+dnl Check for srtp library
+dnl ======================
+tmp_CXXFLAGS="$CXXFLAGS"
+tmp_CPPFLAGS="$CPPFLAGS"
+tmp_CFLAGS="$CFLAGS"
+tmp_LDFLAGS="$LDFLAGS"
+tmp_LIBS="$LIBS"
+CXXFLAGS=""
+CPPFLAGS=""
+CFLAGS=""
+LDFLAGS=""
+LIBS=""
+AC_CHECK_HEADER(srtp/srtp.h, , AC_MSG_ERROR([*** srtp header file not found!]))
+AC_CHECK_LIB(srtp, srtp_init, , AC_MSG_ERROR([*** srtp library not found!]))
+SRTP_CFLAGS="$CXXFLAGS $CPPFLAGS $CFLAGS"
+SRTP_LIBS="$LDFLAGS $LIBS"
+CXXFLAGS="$tmp_CXXFLAGS"
+CPPFLAGS="$tmp_CPPFLAGS"
+CFLAGS="$tmp_CFLAGS"
+LDFLAGS="$tmp_LDFLAGS"
+LIBS="$tmp_LIBS"
+AC_SUBST(SRTP_CFLAGS)
+AC_SUBST(SRTP_LIBS)
+
+AC_PROG_CXX
+
+AC_PROG_LIBTOOL
+AM_PROG_LIBTOOL
+
+AM_CONFIG_HEADER(config.h)
+AC_STDC_HEADERS
+
+AC_OUTPUT(
+ Makefile
+ src/Makefile)
+