summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2013-12-04 14:04:33 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2013-12-04 14:04:33 +0100
commit774e2789774dcb35f7e9e4cfa41632e13e2ac09e (patch)
tree61e473e901a89b6fb8a0652797e2b554b239c02e /configure.ac
parent69ed1b39d8ee855e9fe4c7b0ea0cffea951c1d59 (diff)
Modernise autotools files. Convert all tests to cppunit.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac86
1 files changed, 86 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..52c6481
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,86 @@
+# Filename: configure.in
+
+AC_INIT([lrtp], [0.0.1])
+AC_CONFIG_SRCDIR([src/lrtp.cc])
+AM_INIT_AUTOMAKE
+
+dnl ======================
+dnl Compile with debug options
+dnl ======================
+AC_ARG_WITH(debug,
+ [ --with-debug build with debug support (default=no)],
+ [],
+ [with_debug=no])
+if test x$with_debug == xyes; then
+ AC_MSG_WARN([*** Building with debug support!])
+ AC_DEFINE_UNQUOTED(WITH_DEBUG, , [The project is configured to use debug output])
+ CXXFLAGS="$CXXFLAGS -D_FORTIFY_SOURCE=2 -fstack-protector -Wall -Werror -g -O0"
+fi
+
+dnl ======================
+dnl Init pkg-config
+dnl ======================
+PKG_PROG_PKG_CONFIG(0.23)
+
+dnl ======================
+dnl Compile with encryption
+dnl ======================
+AC_ARG_WITH(crypto,
+ [ --with-crypto build with crypto support (default=yes)],
+ [],
+ [with_crypto=yes])
+if test x$with_crypto == xyes; then
+ AC_MSG_WARN([*** Building with crypto support!])
+ CXXFLAGS="$CXXFLAGS -DUSE_CRYPTO"
+fi
+
+dnl ======================
+dnl Check if tests should be built.
+dnl ======================
+AC_ARG_WITH(test,
+ [ --with-test build tests (default=no)],
+ [],
+ [with_test=no])
+if test x$with_test == xyes; then
+ AM_PATH_CPPUNIT(1.9.6)
+fi
+
+dnl ======================
+dnl Check for srtp library
+dnl ======================
+tmp_CXXFLAGS="$CXXFLAGS"
+tmp_CPPFLAGS="$CPPFLAGS"
+tmp_CFLAGS="$CFLAGS"
+tmp_LDFLAGS="$LDFLAGS"
+tmp_LIBS="$LIBS"
+CXXFLAGS=""
+CPPFLAGS=""
+CFLAGS=""
+LDFLAGS=""
+LIBS=""
+AC_CHECK_HEADER(srtp/srtp.h, , AC_MSG_ERROR([*** srtp header file not found!]))
+AC_CHECK_LIB(srtp, srtp_init, , AC_MSG_ERROR([*** srtp library not found!]))
+SRTP_CFLAGS="$CXXFLAGS $CPPFLAGS $CFLAGS"
+SRTP_LIBS="$LDFLAGS $LIBS"
+CXXFLAGS="$tmp_CXXFLAGS"
+CPPFLAGS="$tmp_CPPFLAGS"
+CFLAGS="$tmp_CFLAGS"
+LDFLAGS="$tmp_LDFLAGS"
+LIBS="$tmp_LIBS"
+AC_SUBST(SRTP_CFLAGS)
+AC_SUBST(SRTP_LIBS)
+
+AC_PROG_CXX
+
+AC_PROG_LIBTOOL
+AM_PROG_LIBTOOL
+
+AM_CONFIG_HEADER(config.h)
+AC_STDC_HEADERS
+
+AC_OUTPUT(
+ Makefile
+ src/Makefile
+ test/Makefile
+ lrtp.pc)
+