summaryrefslogtreecommitdiff
path: root/server/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'server/src/Makefile.am')
-rw-r--r--server/src/Makefile.am22
1 files changed, 13 insertions, 9 deletions
diff --git a/server/src/Makefile.am b/server/src/Makefile.am
index 7077301..52eade2 100644
--- a/server/src/Makefile.am
+++ b/server/src/Makefile.am
@@ -1,7 +1,7 @@
bin_PROGRAMS = pracrod
-pracrod_LDADD = $(LD_EFENCE) $(PQXX_LIBS) $(CONFIG_LIBS) $(LUA_LIBS)
+pracrod_LDADD = $(LD_EFENCE) $(PQXX_LIBS) $(CONFIG_LIBS) $(LUA_LIBS) -lpthread
pracrod_CXXFLAGS = $(PQXX_CXXFLAGS) $(CONFIG_CXXFLAGS) $(LUA_CXXFLAGS)
@@ -16,7 +16,6 @@ pracrod_SOURCES = \
journal_commit.cc \
log.cc \
luaquerymapper.cc \
- macro_parser.cc \
resumeparser.cc \
saxparser.cc \
server.cc \
@@ -24,7 +23,8 @@ pracrod_SOURCES = \
transactionparser.cc \
tcpsocket.cc \
tostring.cc \
- uid.cc
+ uid.cc \
+ widgetgenerator.cc
EXTRA_DIST = \
configuration.h \
@@ -37,8 +37,6 @@ EXTRA_DIST = \
journal_commit.h \
log.h \
luaquerymapper.h \
- macro.h \
- macro_parser.h \
resumeparser.h \
saxparser.h \
server.h \
@@ -46,13 +44,15 @@ EXTRA_DIST = \
transactionparser.h \
tcpsocket.h \
tostring.h \
- uid.h
+ uid.h \
+ widgetgenerator.h
TESTFILES = \
test_queryhandler \
test_queryparser \
test_luaquerymapper \
- test_templateparser
+ test_templateparser \
+ test_server
TESTLOGS = `for F in ${TESTFILES}; do echo $$F.log; done`
@@ -72,6 +72,10 @@ test_luaquerymapper: luaquerymapper.cc
@../../tools/test luaquerymapper.cc queryparser.cc queryhandler.cc tcpsocket.cc exception.cc tostring.cc uid.cc log.cc saxparser.cc -lexpat $(LUA_LIBS)
test_templateparser: templateparser.cc
- @../../tools/test templateparser.cc saxparser.cc -lexpat
+ @../../tools/test templateparser.cc saxparser.cc -lexpat -DXML="\"../xml\""
-CLEANFILES = $(TESTFILES) $(TESTLOGS)
+test_server: server.cc
+ @../../tools/test server.cc templateparser.cc saxparser.cc queryparser.cc queryhandler.cc luaquerymapper.cc tcpsocket.cc exception.cc log.cc configuration.cc tostring.cc transactionparser.cc widgetgenerator.cc -lexpat $(LUA_LIBS) $(CONFIG_LIBS) -DXML="\"../xml\""
+ killall -9 test_server
+
+CLEANFILES = $(TESTFILES) $(TESTLOGS) *~