summaryrefslogtreecommitdiff
path: root/server/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'server/src/Makefile.am')
-rw-r--r--server/src/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/server/src/Makefile.am b/server/src/Makefile.am
index 251560b..7b66663 100644
--- a/server/src/Makefile.am
+++ b/server/src/Makefile.am
@@ -47,3 +47,27 @@ EXTRA_DIST = \
tcpsocket.h \
tostring.h \
uid.h
+
+TESTFILES = \
+ test_queryhandler \
+ test_queryparser \
+ test_luaquerymapper
+
+TESTLOGS = `for F in ${TESTFILES}; do echo $$F.log; done`
+
+test: $(TESTFILES)
+ @echo "All tests done."
+
+test_clean:
+ rm -f $(TESTFILES)
+
+test_queryhandler: queryhandler.cc
+ @../../tools/test queryhandler.cc tcpsocket.cc exception.cc tostring.cc uid.cc log.cc
+
+test_queryparser: queryparser.cc
+ @../../tools/test queryparser.cc queryhandler.cc tcpsocket.cc exception.cc tostring.cc uid.cc log.cc saxparser.cc -lexpat
+
+test_luaquerymapper: luaquerymapper.cc
+ @../../tools/test luaquerymapper.cc queryparser.cc queryhandler.cc tcpsocket.cc exception.cc tostring.cc uid.cc log.cc saxparser.cc -lexpat $(LUA_LIBS)
+
+CLEANFILES = $(TESTFILES) $(TESTLOGS)