summaryrefslogtreecommitdiff
path: root/server/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'server/src/Makefile.am')
-rw-r--r--server/src/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/server/src/Makefile.am b/server/src/Makefile.am
index 6721b8c..75e72d9 100644
--- a/server/src/Makefile.am
+++ b/server/src/Makefile.am
@@ -20,7 +20,9 @@ pracrod_SOURCES = \
luaformatmapper.cc \
luaformatmapperutils.cc \
luaquerymapper.cc \
+ luaresume.cc \
macroparser.cc \
+ mltokenizer.cc \
resumeparser.cc \
saxparser.cc \
server.cc \
@@ -45,7 +47,9 @@ EXTRA_DIST = \
luaformatmapper.h \
luaformatmapperutils.h \
luaquerymapper.h \
+ luaresume.h \
macroparser.h \
+ mltokenizer.h \
resumeparser.h \
saxparser.h \
server.h \
@@ -64,7 +68,8 @@ TESTFILES = \
test_server \
test_database \
test_macroparser \
- test_xml_encode_decode
+ test_xml_encode_decode \
+ test_mltokenizer
TESTLOGS = `for F in ${TESTFILES}; do echo $$F.log; done`
@@ -75,8 +80,11 @@ test: $(TESTFILES)
test_clean:
rm -f $(TESTFILES)
-test_formattools: formattools.cc luaformatmapper.cc luaformatmapperutils.cc
- @../../tools/test formattools.cc luaformatmapper.cc luaformatmapperutils.cc exception.cc log.cc $(LUA_LIBS)
+test_mltokenizer: mltokenizer.cc
+ @../../tools/test mltokenizer.cc
+
+test_formattools: formattools.cc luaformatmapper.cc luaformatmapperutils.cc mltokenizer.cc
+ @../../tools/test formattools.cc luaformatmapper.cc mltokenizer.cc luaformatmapperutils.cc exception.cc log.cc $(LUA_LIBS)
test_queryhandler: queryhandler.cc
@../../tools/test queryhandler.cc tcpsocket.cc exception.cc log.cc