summaryrefslogtreecommitdiff
path: root/server/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'server/src/Makefile.am')
-rw-r--r--server/src/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/server/src/Makefile.am b/server/src/Makefile.am
index 3bc3069..399d7fa 100644
--- a/server/src/Makefile.am
+++ b/server/src/Makefile.am
@@ -25,6 +25,7 @@ pracrod_SOURCES = \
macroparser.cc \
pracrodao.cc \
pracrodaopgsql.cc \
+ pracrodaotest.cc \
resumeparser.cc \
saxparser.cc \
server.cc \
@@ -59,6 +60,7 @@ macrotool_SOURCES = \
macrotool_util.cc \
pracrodao.cc \
pracrodaopgsql.cc \
+ pracrodaotest.cc \
saxparser.cc \
templateparser.cc \
versionstr.cc
@@ -88,6 +90,7 @@ EXTRA_DIST = \
macrotool_util.h \
pracrodao.h \
pracrodaopgsql.h \
+ pracrodaotest.h \
resumeparser.h \
saxparser.h \
server.h \
@@ -106,6 +109,8 @@ EXTRA_DIST = \
################
TESTFILES = \
+ test_pracrodaotest \
+ test_widgetgenerator \
test_configurationparser \
test_exception \
test_templateheaderparser \
@@ -143,6 +148,21 @@ test: $(TESTFILES)
test_clean:
rm -f $(TESTFILES) $(TESTLOGS)
+TEST_PRACRODAOTEST_FILES = \
+ pracrodaotest.cc \
+ pracrodao.cc \
+ $(BASICFILES)
+test_pracrodaotest: $(TEST_PRACRODAOTEST_FILES)
+ @../../tools/test $(TEST_PRACRODAOTEST_FILES) $(BASICFLAGS)
+
+TEST_WIDGETGENERATOR_FILES = \
+ widgetgenerator.cc \
+ xml_encode_decode.cc \
+ luaquerymapper.cc \
+ $(BASICFILES)
+test_widgetgenerator: $(TEST_WIDGETGENERATOR_FILES)
+ @../../tools/test $(TEST_WIDGETGENERATOR_FILES) $(BASICFLAGS) $(LUA_LIBS)
+
TEST_CONFIGURATIONPARSER_FILES = \
configurationparser.cc \
configuration.cc \