summaryrefslogtreecommitdiff
path: root/server/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'server/src/Makefile.am')
-rw-r--r--server/src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/server/src/Makefile.am b/server/src/Makefile.am
index 3449e6b..6721b8c 100644
--- a/server/src/Makefile.am
+++ b/server/src/Makefile.am
@@ -18,6 +18,7 @@ pracrod_SOURCES = \
journal_commit.cc \
log.cc \
luaformatmapper.cc \
+ luaformatmapperutils.cc \
luaquerymapper.cc \
macroparser.cc \
resumeparser.cc \
@@ -42,6 +43,7 @@ EXTRA_DIST = \
journal_commit.h \
log.h \
luaformatmapper.h \
+ luaformatmapperutils.h \
luaquerymapper.h \
macroparser.h \
resumeparser.h \
@@ -73,8 +75,8 @@ test: $(TESTFILES)
test_clean:
rm -f $(TESTFILES)
-test_formattools: formattools.cc luaformatmapper.cc
- @../../tools/test formattools.cc luaformatmapper.cc exception.cc log.cc $(LUA_LIBS)
+test_formattools: formattools.cc luaformatmapper.cc luaformatmapperutils.cc
+ @../../tools/test formattools.cc luaformatmapper.cc luaformatmapperutils.cc exception.cc log.cc $(LUA_LIBS)
test_queryhandler: queryhandler.cc
@../../tools/test queryhandler.cc tcpsocket.cc exception.cc log.cc