summaryrefslogtreecommitdiff
path: root/server/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'server/configure.in')
-rw-r--r--server/configure.in9
1 files changed, 5 insertions, 4 deletions
diff --git a/server/configure.in b/server/configure.in
index 9d6b803..a5af2c1 100644
--- a/server/configure.in
+++ b/server/configure.in
@@ -8,10 +8,11 @@ dnl Compile with debug options
dnl ======================
AC_ARG_WITH(debug,
[ --with-debug build with debug support (default=no)],
- [with_debug=yes],
+ [],
[with_debug=no])
if test x$with_debug == xyes; then
AC_MSG_WARN([*** Building with debug support!])
+ AC_DEFINE_UNQUOTED(WITH_DEBUG, , [The project is configured to use debug output])
CXXFLAGS="$CXXFLAGS -D_FORTIFY_SOURCE=2 -fstack-protector -Wall -Werror -g -O0"
fi
@@ -24,7 +25,7 @@ AC_ARG_WITH(pentominos,
[with_pentominos=yes])
if test x$with_pentominos == xno; then
AC_MSG_WARN([*** Building without pentominos support!])
- CXXFLAGS="$CXXFLAGS -DWITHOUT_PENTOMINOS"
+ AC_DEFINE_UNQUOTED(WITHOUT_PENTOMINOS, , [The project is configured not to use pentomimos])
fi
dnl ======================
@@ -36,7 +37,7 @@ AC_ARG_WITH(uploadserver,
[with_uploadserver=yes])
if test x$with_uploadserver == xno; then
AC_MSG_WARN([*** Building without uploadserver support!])
- CXXFLAGS="$CXXFLAGS -DWITHOUT_UPLOADSERVER"
+ AC_DEFINE_UNQUOTED(WITHOUT_UPLOADSERVER, , [The project is configured not to use the upload server])
fi
dnl ======================
@@ -48,7 +49,7 @@ AC_ARG_WITH(db,
[with_db=yes])
if test x$with_db == xno; then
AC_MSG_WARN([*** Building without db support!])
- CXXFLAGS="$CXXFLAGS -DWITHOUT_DB"
+ AC_DEFINE_UNQUOTED(WITHOUT_DB, , [The project is configured not to use the db])
fi
AC_PROG_CXX