summaryrefslogtreecommitdiff
path: root/server/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'server/configure.in')
-rw-r--r--server/configure.in26
1 files changed, 25 insertions, 1 deletions
diff --git a/server/configure.in b/server/configure.in
index 79a14e1..9d6b803 100644
--- a/server/configure.in
+++ b/server/configure.in
@@ -19,7 +19,7 @@ dnl ======================
dnl Compile without pentominos support
dnl ======================
AC_ARG_WITH(pentominos,
- [ --with-pentominos build without pentominos support (default=yes)],
+ [ --with-pentominos build with pentominos support (default=yes)],
[],
[with_pentominos=yes])
if test x$with_pentominos == xno; then
@@ -27,6 +27,30 @@ if test x$with_pentominos == xno; then
CXXFLAGS="$CXXFLAGS -DWITHOUT_PENTOMINOS"
fi
+dnl ======================
+dnl Compile without uploadserver support
+dnl ======================
+AC_ARG_WITH(uploadserver,
+ [ --with-uploadserver build with uploadserver support (default=yes)],
+ [],
+ [with_uploadserver=yes])
+if test x$with_uploadserver == xno; then
+ AC_MSG_WARN([*** Building without uploadserver support!])
+ CXXFLAGS="$CXXFLAGS -DWITHOUT_UPLOADSERVER"
+fi
+
+dnl ======================
+dnl Compile without db support
+dnl ======================
+AC_ARG_WITH(db,
+ [ --with-db build with db support (default=yes)],
+ [],
+ [with_db=yes])
+if test x$with_db == xno; then
+ AC_MSG_WARN([*** Building without db support!])
+ CXXFLAGS="$CXXFLAGS -DWITHOUT_DB"
+fi
+
AC_PROG_CXX
AC_PROG_LIBTOOL