summaryrefslogtreecommitdiff
path: root/server/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'server/configure.in')
-rw-r--r--server/configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/server/configure.in b/server/configure.in
index 7449594..cd5b937 100644
--- a/server/configure.in
+++ b/server/configure.in
@@ -57,6 +57,23 @@ else
PKG_CHECK_MODULES(PQXX, libpqxx >= 2.6.8)
fi
+dnl ======================
+dnl Compile with ssl support?
+dnl ======================
+AC_ARG_WITH(ssl,
+ [ --with-ssl build with ssl support, requires microhttpd to be build with ssl support (default=yes)],
+ [],
+ [with_ssl=yes])
+if test x$with_ssl == xno; then
+ AC_MSG_WARN([*** Building without ssl support!])
+ AC_DEFINE_UNQUOTED(WITHOUT_SSL, , [The project is configured not to use ssl])
+else
+ AC_MSG_WARN([*** Building with ssl support!])
+ dnl ======================
+ dnl TODO: Check for ssl support in microhttpd
+ dnl ======================
+fi
+
AC_PROG_CXX
AC_PROG_LIBTOOL