summaryrefslogtreecommitdiff
path: root/server/src/Makefile.am
diff options
context:
space:
mode:
authordeva <deva>2009-07-22 15:00:29 +0000
committerdeva <deva>2009-07-22 15:00:29 +0000
commit7e349e2789a633a6014baea63aeb7932e024c917 (patch)
tree0b7b20adf693e3991f4410368255fd05aa8aab0d /server/src/Makefile.am
parent8109ada79a24f03e00ebc199ebfdb58e70b054d9 (diff)
Changed the way the macros are looked up in the filesystem (now they are parsed and indexed using version numbers). Updated all unit tests, to compile and run again.
Diffstat (limited to 'server/src/Makefile.am')
-rw-r--r--server/src/Makefile.am48
1 files changed, 34 insertions, 14 deletions
diff --git a/server/src/Makefile.am b/server/src/Makefile.am
index 0589630..99863f0 100644
--- a/server/src/Makefile.am
+++ b/server/src/Makefile.am
@@ -20,6 +20,8 @@ pracrod_SOURCES = \
log.cc \
luaquerymapper.cc \
luaresume.cc \
+ macroheaderparser.cc \
+ macrolist.cc \
macroparser.cc \
pracrodao.cc \
pracrodaopgsql.cc \
@@ -30,6 +32,7 @@ pracrod_SOURCES = \
transactionparser.cc \
tcpsocket.cc \
utf8.cc \
+ version.cc \
widgetgenerator.cc \
xml_encode_decode.cc
@@ -45,6 +48,8 @@ macrotool_SOURCES = \
database.cc \
exception.cc \
log.cc \
+ macroheaderparser.cc \
+ macrolist.cc \
macroparser.cc \
macrotool_dump.cc \
macrotool_fieldnames.cc \
@@ -53,7 +58,8 @@ macrotool_SOURCES = \
pracrodao.cc \
pracrodaopgsql.cc \
saxparser.cc \
- templateparser.cc
+ templateparser.cc \
+ version.cc
EXTRA_DIST = \
configuration.h \
@@ -71,6 +77,8 @@ EXTRA_DIST = \
log.h \
luaquerymapper.h \
luaresume.h \
+ macroheaderparser.h \
+ macrolist.h \
macroparser.h \
macrotool_dump.h \
macrotool_fieldnames.h \
@@ -85,17 +93,20 @@ EXTRA_DIST = \
transactionparser.h \
tcpsocket.h \
utf8.h \
+ version.h \
widgetgenerator.h \
xml_encode_decode.h
TESTFILES = \
+ test_version \
+ test_macrolist \
test_queryhandlerpentominos \
test_queryhandlerpracro \
test_queryparser \
test_luaquerymapper \
test_templateparser \
test_server \
- test_database \
+ test_pracrodaopgsql \
test_macroparser \
test_xml_encode_decode \
test_journal_commit
@@ -103,42 +114,51 @@ TESTFILES = \
TESTLOGS = `for F in ${TESTFILES}; do echo $$F.log; done`
+BASICS = "-I.. -DHAVE_CONFIG_H exception.cc log.cc debug.cc configuration.cc utf8.cc"
+PARSERBASICS = "saxparser.cc -lexpat"
+DBBASICS = "database.cc pracrodao.cc pracrodaopgsql.cc $(PQXX_LIBS) $(PQXX_CXXFLAGS)"
+
test: $(TESTFILES)
@echo "All tests done."
test_clean:
rm -f $(TESTFILES)
+test_version: version.cc
+ @../../tools/test version.cc
+
+test_macrolist: macrolist.cc
+ @../../tools/test macrolist.cc version.cc macroheaderparser.cc $(PARSERBASICS) $(BASICS)
+
test_queryhandlerpentominos: queryhandlerpentominos.cc
- @../../tools/test queryhandlerpentominos.cc tcpsocket.cc exception.cc log.cc
+ @../../tools/test queryhandlerpentominos.cc tcpsocket.cc queryparser.cc $(PARSERBASICS) $(BASICS)
test_queryhandlerpracro: queryhandlerpracro.cc
- @../../tools/test queryhandlerpracro.cc tcpsocket.cc exception.cc log.cc
+ @../../tools/test queryhandlerpracro.cc tcpsocket.cc queryparser.cc $(DBBASICS) $(PARSERBASICS) $(BASICS)
test_queryparser: queryparser.cc
- @../../tools/test queryparser.cc queryhandler.cc tcpsocket.cc exception.cc log.cc saxparser.cc -lexpat
+ @../../tools/test queryparser.cc queryhandlerpentominos.cc tcpsocket.cc $(BASICS) $(PARSERBASICS)
test_luaquerymapper: luaquerymapper.cc
- @../../tools/test luaquerymapper.cc queryparser.cc queryhandler.cc tcpsocket.cc exception.cc log.cc saxparser.cc -lexpat $(LUA_LIBS)
+ @../../tools/test luaquerymapper.cc queryparser.cc queryhandlerpentominos.cc tcpsocket.cc $(BASICS) $(PARSERBASICS) $(LUA_LIBS)
test_templateparser: templateparser.cc
- @../../tools/test templateparser.cc saxparser.cc exception.cc log.cc -lexpat -DXML="\"../xml\""
+ @../../tools/test templateparser.cc $(PARSERBASICS) $(BASICS)
test_macroparser: macroparser.cc
- @../../tools/test macroparser.cc saxparser.cc exception.cc log.cc -lexpat -DXML="\"../xml\""
+ @../../tools/test macroparser.cc $(PARSERBASICS) $(BASICS)
test_server: server.cc
- @../../tools/test server.cc templateparser.cc saxparser.cc queryparser.cc queryhandler.cc luaquerymapper.cc tcpsocket.cc exception.cc log.cc configuration.cc transactionparser.cc widgetgenerator.cc database.cc macroparser.cc xml_encode_decode.cc -lexpat $(LUA_LIBS) $(CONFIG_LIBS) $(PQXX_LIBS) $(PQXX_CXXFLAGS) -DXML="\"../xml\""
-
-#killall -9 test_server
+ @../../tools/test server.cc templateparser.cc queryparser.cc queryhandlerpentominos.cc journal_commit.cc macrolist.cc queryhandlerpracro.cc macroheaderparser.cc version.cc resumeparser.cc luaquerymapper.cc tcpsocket.cc $(BASICS) transactionparser.cc widgetgenerator.cc database.cc pracrodao.cc pracrodaopgsql.cc luaresume.cc macroparser.cc xml_encode_decode.cc $(PARSERBASICS) $(LUA_LIBS) $(CONFIG_LIBS) $(PQXX_LIBS) $(PQXX_CXXFLAGS)
+ @sleep 1s; killall -9 test_server
-test_database: database.cc
- @../../tools/test database.cc $(PQXX_LIBS) $(PQXX_CXXFLAGS) -I..
+test_pracrodaopgsql: pracrodaopgsql.cc
+ @../../tools/test pracrodaopgsql.cc pracrodao.cc $(BASICS) $(PQXX_LIBS) $(PQXX_CXXFLAGS) -I..
test_xml_encode_decode: xml_encode_decode.cc
@../../tools/test xml_encode_decode.cc
test_journal_commit: journal_commit.cc
- @../../tools/test journal_commit.cc debug.cc -I..
+ @../../tools/test journal_commit.cc templateparser.cc $(PARSERBASICS) $(BASICS)
CLEANFILES = $(TESTFILES) $(TESTLOGS) *~