summaryrefslogtreecommitdiff
path: root/server/src/Makefile.am
diff options
context:
space:
mode:
authordeva <deva>2008-05-16 15:00:12 +0000
committerdeva <deva>2008-05-16 15:00:12 +0000
commitd22c5966c130ef7768bac7914cb4dafa74088036 (patch)
tree9e0cffb41f582cdf01f592257dd6c85677241f2e /server/src/Makefile.am
parent3f2a5d6e373a79260594382c67d693d4b97c4ffa (diff)
Worked on the connection of the various elements of the server.
Diffstat (limited to 'server/src/Makefile.am')
-rw-r--r--server/src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/server/src/Makefile.am b/server/src/Makefile.am
index 7b66663..7077301 100644
--- a/server/src/Makefile.am
+++ b/server/src/Makefile.am
@@ -51,7 +51,8 @@ EXTRA_DIST = \
TESTFILES = \
test_queryhandler \
test_queryparser \
- test_luaquerymapper
+ test_luaquerymapper \
+ test_templateparser
TESTLOGS = `for F in ${TESTFILES}; do echo $$F.log; done`
@@ -70,4 +71,7 @@ test_queryparser: queryparser.cc
test_luaquerymapper: luaquerymapper.cc
@../../tools/test luaquerymapper.cc queryparser.cc queryhandler.cc tcpsocket.cc exception.cc tostring.cc uid.cc log.cc saxparser.cc -lexpat $(LUA_LIBS)
+test_templateparser: templateparser.cc
+ @../../tools/test templateparser.cc saxparser.cc -lexpat
+
CLEANFILES = $(TESTFILES) $(TESTLOGS)