summaryrefslogtreecommitdiff
path: root/server/src/Makefile.am
diff options
context:
space:
mode:
authordeva <deva>2008-05-23 14:55:39 +0000
committerdeva <deva>2008-05-23 14:55:39 +0000
commit158915fafe286df69a68374032187ae283eb4ded (patch)
tree2f5b593ed9413039bb2b3b0828cb59cb226a39ba /server/src/Makefile.am
parent5dac0856cb400a4f40280e7caae188781dac7b85 (diff)
Did a lot of work on the database class.
Diffstat (limited to 'server/src/Makefile.am')
-rw-r--r--server/src/Makefile.am21
1 files changed, 11 insertions, 10 deletions
diff --git a/server/src/Makefile.am b/server/src/Makefile.am
index 52eade2..c21b814 100644
--- a/server/src/Makefile.am
+++ b/server/src/Makefile.am
@@ -22,8 +22,6 @@ pracrod_SOURCES = \
templateparser.cc \
transactionparser.cc \
tcpsocket.cc \
- tostring.cc \
- uid.cc \
widgetgenerator.cc
EXTRA_DIST = \
@@ -43,8 +41,6 @@ EXTRA_DIST = \
templateparser.h \
transactionparser.h \
tcpsocket.h \
- tostring.h \
- uid.h \
widgetgenerator.h
TESTFILES = \
@@ -52,7 +48,8 @@ TESTFILES = \
test_queryparser \
test_luaquerymapper \
test_templateparser \
- test_server
+ test_server \
+ test_database
TESTLOGS = `for F in ${TESTFILES}; do echo $$F.log; done`
@@ -63,19 +60,23 @@ test_clean:
rm -f $(TESTFILES)
test_queryhandler: queryhandler.cc
- @../../tools/test queryhandler.cc tcpsocket.cc exception.cc tostring.cc uid.cc log.cc
+ @../../tools/test queryhandler.cc tcpsocket.cc exception.cc uid.cc log.cc
test_queryparser: queryparser.cc
- @../../tools/test queryparser.cc queryhandler.cc tcpsocket.cc exception.cc tostring.cc uid.cc log.cc saxparser.cc -lexpat
+ @../../tools/test queryparser.cc queryhandler.cc tcpsocket.cc exception.cc uid.cc log.cc saxparser.cc -lexpat
test_luaquerymapper: luaquerymapper.cc
- @../../tools/test luaquerymapper.cc queryparser.cc queryhandler.cc tcpsocket.cc exception.cc tostring.cc uid.cc log.cc saxparser.cc -lexpat $(LUA_LIBS)
+ @../../tools/test luaquerymapper.cc queryparser.cc queryhandler.cc tcpsocket.cc exception.cc uid.cc log.cc saxparser.cc -lexpat $(LUA_LIBS)
test_templateparser: templateparser.cc
@../../tools/test templateparser.cc saxparser.cc -lexpat -DXML="\"../xml\""
test_server: server.cc
- @../../tools/test server.cc templateparser.cc saxparser.cc queryparser.cc queryhandler.cc luaquerymapper.cc tcpsocket.cc exception.cc log.cc configuration.cc tostring.cc transactionparser.cc widgetgenerator.cc -lexpat $(LUA_LIBS) $(CONFIG_LIBS) -DXML="\"../xml\""
- killall -9 test_server
+ @../../tools/test server.cc templateparser.cc saxparser.cc queryparser.cc queryhandler.cc luaquerymapper.cc tcpsocket.cc exception.cc log.cc configuration.cc transactionparser.cc widgetgenerator.cc -lexpat $(LUA_LIBS) $(CONFIG_LIBS) -DXML="\"../xml\""
+
+#killall -9 test_server
+
+test_database: database.cc
+ @../../tools/test database.cc $(PQXX_LIBS) $(PQXX_CXXFLAGS)
CLEANFILES = $(TESTFILES) $(TESTLOGS) *~