summaryrefslogtreecommitdiff
path: root/server/configure.in
diff options
context:
space:
mode:
authordeva <deva>2010-01-04 11:01:30 +0000
committerdeva <deva>2010-01-04 11:01:30 +0000
commitfc6e95c57f8f7f0acc083daf15dbac828e627e20 (patch)
tree79132d6c4f5dff5a848c6dbee3f6e1e1d50ec43b /server/configure.in
parent99832c46482751486e3348f2e5e18ee46d0a2856 (diff)
Added config, cli and compiletime check for ssl usage. Still needs to check is microhttpd has ssl support.
Diffstat (limited to 'server/configure.in')
-rw-r--r--server/configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/server/configure.in b/server/configure.in
index 7449594..cd5b937 100644
--- a/server/configure.in
+++ b/server/configure.in
@@ -57,6 +57,23 @@ else
PKG_CHECK_MODULES(PQXX, libpqxx >= 2.6.8)
fi
+dnl ======================
+dnl Compile with ssl support?
+dnl ======================
+AC_ARG_WITH(ssl,
+ [ --with-ssl build with ssl support, requires microhttpd to be build with ssl support (default=yes)],
+ [],
+ [with_ssl=yes])
+if test x$with_ssl == xno; then
+ AC_MSG_WARN([*** Building without ssl support!])
+ AC_DEFINE_UNQUOTED(WITHOUT_SSL, , [The project is configured not to use ssl])
+else
+ AC_MSG_WARN([*** Building with ssl support!])
+ dnl ======================
+ dnl TODO: Check for ssl support in microhttpd
+ dnl ======================
+fi
+
AC_PROG_CXX
AC_PROG_LIBTOOL