summaryrefslogtreecommitdiff
path: root/server/configure.in
diff options
context:
space:
mode:
authordeva <deva>2008-05-20 14:03:10 +0000
committerdeva <deva>2008-05-20 14:03:10 +0000
commit556f00e4af55e78836c45f47b0662ab44bbb8b48 (patch)
treea5c315b35d400a397a35a86b86fe656d3a829af9 /server/configure.in
parent91d56787bec83a3a7c2ad6afd84d2b82c5d869b9 (diff)
Made fixes pointed out by GCC 4.2 and -D_FORTIFY_SOURCES=2
Diffstat (limited to 'server/configure.in')
-rw-r--r--server/configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/server/configure.in b/server/configure.in
index f2c6f7e..8cfb673 100644
--- a/server/configure.in
+++ b/server/configure.in
@@ -3,6 +3,15 @@
AC_INIT(src/pracrod.cc)
AM_INIT_AUTOMAKE( pracrod, 0.0.1 )
+dnl ======================
+dnl Compile with debug options
+dnl ======================
+AC_ARG_WITH(debug, [ --with-debug build with debug support])
+if test x$with_debug == xyes; then
+ AC_MSG_WARN([*** Building with debug support!])
+ CXXFLAGS="$CXXFLAGS -D_FORTIFY_SOURCE=2 -fstack-protector -Wall -Werror -g -O0"
+fi
+
AC_PROG_CXX
AC_PROG_LIBTOOL
@@ -23,7 +32,6 @@ fi
AC_SUBST(MYPREFIX)
AC_DEFINE_UNQUOTED(ETC, "$MYPREFIX/etc", [The path to the config files])
-
dnl ======================
dnl Use efence in linking and includes
dnl ======================