summaryrefslogtreecommitdiff
path: root/server/configure.in
diff options
context:
space:
mode:
authordeva <deva>2009-02-17 12:07:03 +0000
committerdeva <deva>2009-02-17 12:07:03 +0000
commit417532e9def7d5568ec9804a65078f2b42707a4a (patch)
treeef26189f18fe19a4b9a92a8b07b957688e6e0eca /server/configure.in
parent8dde5e5e15434eb83e8514220973e3cf8b56a393 (diff)
Made the --with-db=no configure option actually compile without the db (even without an installed libpqxx).
Diffstat (limited to 'server/configure.in')
-rw-r--r--server/configure.in13
1 files changed, 5 insertions, 8 deletions
diff --git a/server/configure.in b/server/configure.in
index 013ea9a..9aad9f4 100644
--- a/server/configure.in
+++ b/server/configure.in
@@ -50,6 +50,11 @@ AC_ARG_WITH(db,
if test x$with_db == xno; then
AC_MSG_WARN([*** Building without db support!])
AC_DEFINE_UNQUOTED(WITHOUT_DB, , [The project is configured not to use the db])
+else
+ dnl ======================
+ dnl Check for libpqxx
+ dnl ======================
+ PKG_CHECK_MODULES(PQXX, libpqxx >= 2.6.8)
fi
AC_PROG_CXX
@@ -110,19 +115,11 @@ dnl Create the XML var i config.h
dnl ======================
AC_DEFINE_UNQUOTED(XML, "$MYPREFIX/share/xml", [The path to the xml files])
-
dnl ======================
dnl Check for getopt
dnl ======================
AC_HAVE_HEADERS(getopt.h)
-
-dnl ======================
-dnl Check for libpqxx
-dnl ======================
-PKG_CHECK_MODULES(PQXX, libpqxx >= 2.6.8)
-
-
dnl ======================
dnl Check for libconfig++
dnl ======================