summaryrefslogtreecommitdiff
path: root/server/configure.in
diff options
context:
space:
mode:
authordeva <deva>2008-05-23 14:55:39 +0000
committerdeva <deva>2008-05-23 14:55:39 +0000
commit158915fafe286df69a68374032187ae283eb4ded (patch)
tree2f5b593ed9413039bb2b3b0828cb59cb226a39ba /server/configure.in
parent5dac0856cb400a4f40280e7caae188781dac7b85 (diff)
Did a lot of work on the database class.
Diffstat (limited to 'server/configure.in')
-rw-r--r--server/configure.in18
1 files changed, 16 insertions, 2 deletions
diff --git a/server/configure.in b/server/configure.in
index 8cfb673..01afcad 100644
--- a/server/configure.in
+++ b/server/configure.in
@@ -6,7 +6,7 @@ AM_INIT_AUTOMAKE( pracrod, 0.0.1 )
dnl ======================
dnl Compile with debug options
dnl ======================
-AC_ARG_WITH(debug, [ --with-debug build with debug support])
+AC_ARG_WITH(debug, [ --with-debug build with debug support])
if test x$with_debug == xyes; then
AC_MSG_WARN([*** Building with debug support!])
CXXFLAGS="$CXXFLAGS -D_FORTIFY_SOURCE=2 -fstack-protector -Wall -Werror -g -O0"
@@ -36,7 +36,7 @@ dnl ======================
dnl Use efence in linking and includes
dnl ======================
AC_ARG_ENABLE(efence,
- [ --enable-efence enable efence - for debugging only (no)],
+ [ --enable-efence enable efence - for debugging only (no)],
[], [ enable_efence=no])
if test "x$enable_efence" = xno; then
enable_efence=no
@@ -47,6 +47,20 @@ else
fi
dnl ======================
+dnl Use duma in linking and includes
+dnl ======================
+AC_ARG_ENABLE(duma,
+ [ --enable-duma enable duma - for debugging only (no)],
+ [], [ enable_duma=no])
+if test "x$enable_duma" = xno; then
+ enable_duma=no
+else
+ LD_EFENCE="-lduma"
+ AC_SUBST(LD_DUMA)
+ AC_DEFINE_UNQUOTED(USE_DUMA, , [Use the duma includes])
+fi
+
+dnl ======================
dnl Check for lua
dnl ======================
PKG_CHECK_MODULES(LUA, lua >= 5.1)