summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 3e962ee..b2fe011 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,7 +1,7 @@
# Rules for the test code (use `make check` to execute)
if ENABLE_TESTS
-TESTS = logintest xmlencodetest connectionhandlertest nodetreetest
+TESTS = logintest xmlencodetest connectionhandlertest nodetreetest acltest
EXTRA_DIST = \
dgunit.h \
@@ -52,4 +52,16 @@ nodetreetest_SOURCES = \
nodetreetest.cc \
dgtest.cc
+acltest_CXXFLAGS = -DOUTPUT=\"acltest\" \
+ $(DEBUG_FLAGS) \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/argon2/include
+acltest_LDFLAGS = $(top_builddir)/src/libargon2.la
+acltest_SOURCES = \
+ $(top_srcdir)/src/acl.cc \
+ $(top_srcdir)/src/hash.cc \
+ scopedfile.cc \
+ acltest.cc \
+ dgtest.cc
+
endif