summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am27
1 files changed, 26 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c8a6560..750fb7c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,19 @@
SUBDIRS = ws
-bin_PROGRAMS = muniad muniacli
+noinst_LTLIBRARIES = libargon2.la
+
+bin_PROGRAMS = muniad muniacli muniapwd
+
+libargon2_la_CFLAGS = \
+ -DARGON2_NO_THREADS -I$(top_srcdir)/argon2/include
+
+libargon2_la_SOURCES = \
+ $(top_srcdir)/argon2/src/argon2.c \
+ $(top_srcdir)/argon2/src/core.c \
+ $(top_srcdir)/argon2/src/blake2/blake2b.c \
+ $(top_srcdir)/argon2/src/thread.c \
+ $(top_srcdir)/argon2/src/encoding.c \
+ $(top_srcdir)/argon2/src/ref.c
muniad_LDADD = $(LIBWEBSOCKETS_LIBS) $(EXPAT_LIBS)
@@ -29,6 +42,18 @@ muniacli_CXXFLAGS = $(LIBWEBSOCKETS_CFLAGS) -I$(top_srcdir)/hugin
muniacli_SOURCES = \
muniacli.cc
+muniapwd_LDADD = libargon2.la
+
+muniapwd_CXXFLAGS = \
+ -std=c++11 \
+ $(LIBWEBSOCKETS_CFLAGS) \
+ -I$(top_srcdir)/argon2/include
+
+muniapwd_SOURCES = \
+ muniapwd.cc \
+ salt.cc \
+ hash.cc
+
EXTRA_DIST = \
connectionhandler.h \
errorcodes.h \