summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am136
1 files changed, 0 insertions, 136 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index 42f8b63..0000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,136 +0,0 @@
-AM_CXXFLAGS := $(CXXFLAGS) $(EXTRA_CXXFLAGS) -I../include $(QT_CXXFLAGS) \
- -DQT_THREAD_SUPPORT \
- -DPIXMAPS=\"$(datadir)/pixmaps\" \
- -DETC=\"$(prefix)/etc/miav\"
-
-bin_PROGRAMS = miav
-
-miav_SOURCES = $(shell if [ $QT_CXXFLAGS ] ; then ../tools/MocList cc; fi ) \
- aa_socket.cc \
- aboutwindow.cc \
- audio_encoder.cc \
- camera.cc \
- cprlisten.cc \
- cprquerydialog.cc \
- daemon.cc \
- decoder.cc \
- dv1394.cc \
- dvfile.cc \
- file.cc \
- frame.cc \
- historywidget.cc \
- img_encoder.cc \
- info.cc \
- info_console.cc \
- info_gui.cc \
- info_simple.cc \
- jpeg_mem_dest.cc \
- libfame_wrapper.cc \
- liblame_wrapper.cc \
- libmplex_wrapper.cc \
- mainwindow.cc \
- messagebox.cc \
- miav.cc \
- miav_daemon.cc \
- miav_config.cc \
- mov_encoder.cc \
- mov_encoder_thread.cc \
- mov_encoder_writer.cc \
- multicast.cc \
- multicast_configuration.cc \
- multiplexer.cc \
- mutex.cc \
- network.cc \
- player.cc \
- server.cc \
- server_status.cc \
- semaphore.cc \
- socket.cc \
- thread.cc \
- threadsafe_queue.cc \
- threadsafe_queue_fifo.cc \
- threadsafe_queue_priority.cc \
- encoder.cc \
- util.cc \
- videowidget.cc \
- yuv_draw.cc
-
-EXTRA_DIST = \
- aa_socket.h \
- aboutwindow.h \
- audio_encoder.h \
- camera.h \
- cprlisten.h \
- cprquerydialog.h \
- daemon.h \
- debug.h \
- decoder.h \
- dv.h \
- dv1394.h \
- dvfile.h \
- file.h \
- font.h \
- frame.h \
- frame_stream.h \
- historywidget.h \
- img_encoder.h \
- info.h \
- info_console.h \
- info_gui.h \
- info_simple.h \
- iso11172-1.h \
- iso11172-2.h \
- iso11172-3.h \
- jpeg_mem_dest.h \
- libfame_wrapper.h \
- liblame_wrapper.h \
- libmplex_wrapper.h \
- mainwindow.h \
- messagebox.h \
- miav.h \
- miav_daemon.h \
- miav_config.h \
- mov_encoder.h \
- mov_encoder_thread.h \
- mov_encoder_writer.h \
- multicast.h \
- multicast_configuration.h \
- multiplexer.h \
- mutex.h \
- network.h \
- package.h \
- player.h \
- queue.h \
- server.h \
- server_status.h \
- semaphore.h \
- socket.h \
- thread.h \
- threadsafe_queue.h \
- threadsafe_queue_fifo.h \
- threadsafe_queue_priority.h \
- encoder.h \
- util.h \
- videowidget.h \
- yuv_draw.h
-
-miav_LDADD := $(shell if [ $QT_CXXFLAGS ] ; then ../tools/MocList o; fi )
-
-miav_MOC = $(shell if [ $QT_CXXFLAGS ] ; then ../tools/MocList cc; fi )
-
-BUILT_SOURCES = $(miav_MOC)
-
-CLEANFILES = $(BUILT_SOURCES)
-
-%.moc.cc: %.h
- $(QTDIR)/bin/$(MOC) -o $@ $<
-
-%.h: %.ui
- $(QTDIR)/bin/$(UIC) -o $@ $<
-
-%.cc: %.ui
- $(QTDIR)/bin/$(UIC) -o $@ -impl $*.h $<
-
-# command for creating .res file from .rc on Win32
-%.res: %.rc
- rc $<