summaryrefslogtreecommitdiff
path: root/miav/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'miav/Makefile.am')
-rw-r--r--miav/Makefile.am64
1 files changed, 64 insertions, 0 deletions
diff --git a/miav/Makefile.am b/miav/Makefile.am
new file mode 100644
index 0000000..cc6f7ad
--- /dev/null
+++ b/miav/Makefile.am
@@ -0,0 +1,64 @@
+AM_CXXFLAGS = $(CXXFLAGS) $(EXTRA_CXXFLAGS) -I../include $(QT_CXXFLAGS) \
+ -DQT_THREAD_SUPPORT ../libmiav/libmiav.la
+
+bin_PROGRAMS = miav
+
+#miav_LDADD = ../libmiav/libmiav.la
+
+miav_SOURCES = $(shell if [ $QT_CXXFLAGS ] ; then ../tools/MocList cc; fi ) \
+ miav.cc \
+ aboutwindow.cc \
+ camera.cc \
+ cprlisten.cc \
+ cprquerydialog.cc \
+ decoder.cc \
+ dvfile.cc \
+ historywidget.cc \
+ info_gui.cc \
+ mainwindow.cc \
+ messagebox.cc \
+ player.cc \
+ encoder.cc \
+ videowidget.cc \
+ yuv_draw.cc
+
+EXTRA_DIST = \
+ aa_socket.h \
+ aboutwindow.h \
+ camera.h \
+ cprlisten.h \
+ cprquerydialog.h \
+ debug.h \
+ decoder.h \
+ dv1394.h \
+ font.h \
+ historywidget.h \
+ info_gui.h \
+ info_simple.h \
+ mainwindow.h \
+ messagebox.h \
+ player.h \
+ encoder.h \
+ videowidget.h \
+ yuv_draw.h
+
+miav_LDADD := $(shell if [ $QT_CXXFLAGS ] ; then ../tools/MocList o; fi )
+
+miav_MOC = $(shell if [ $QT_CXXFLAGS ] ; then ../tools/MocList cc; fi )
+
+BUILT_SOURCES = $(miav_MOC)
+
+CLEANFILES = $(BUILT_SOURCES)
+
+%.moc.cc: %.h
+ $(QTDIR)/bin/$(MOC) -o $@ $<
+
+%.h: %.ui
+ $(QTDIR)/bin/$(UIC) -o $@ $<
+
+%.cc: %.ui
+ $(QTDIR)/bin/$(UIC) -o $@ -impl $*.h $<
+
+# command for creating .res file from .rc on Win32
+%.res: %.rc
+ rc $<