summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in70
1 files changed, 19 insertions, 51 deletions
diff --git a/configure.in b/configure.in
index a9a6952..ee532d6 100644
--- a/configure.in
+++ b/configure.in
@@ -1,6 +1,6 @@
# Filename: configure.in
-AC_INIT(src/miav.cc)
-AM_INIT_AUTOMAKE( miav, 0.3.4 )
+AC_INIT(miav/miav.cc)
+AM_INIT_AUTOMAKE( miav, 0.3.5 )
AC_PROG_CXX
@@ -10,6 +10,14 @@ AM_PROG_LIBTOOL
AM_CONFIG_HEADER(config.h)
AC_STDC_HEADERS
+# Local location of libmiav
+CXXFLAGS="$CXXFLAGS -I../libmiav"
+LDFLAGS="$LDFLAGS -L../libmiav"
+AC_OUTPUT(libmiav/Makefile)
+
+AC_DEFINE_UNQUOTED(ETC, "$prefix/etc/miav", [The path to the config files])
+AC_DEFINE_UNQUOTED(PIXMAPS, "$prefix/share/pixmaps", [The path to the pixmap files])
+
AC_ARG_WITH(debug, [ --with-debug build with debug support])
if test x$with_debug == xyes; then
AC_MSG_WARN([*** Building with debug support!])
@@ -75,54 +83,13 @@ dnl ======================
AC_CHECK_HEADER(lame/lame.h, , AC_MSG_ERROR([*** libLAME (libmp3lame) include files not found!]))
AC_CHECK_LIB(mp3lame, lame_init, , AC_MSG_ERROR([*** libLAME (libmp3lame) not found!]))
-#dnl ======================
-#dnl Check for mplex library
-#dnl ======================
-#PKG_CHECK_MODULES(MPLEX, mjpegtools >= 1.6.1.93, [
-# dnl switch over to c++ to test things
-# AC_LANG_CPLUSPLUS
-# OLD_CPPFLAGS="$CPPFLAGS"
-# CPPFLAGS="$CPPFLAGS $MPLEX_CFLAGS"
-# AC_CHECK_HEADER(interact.hpp, [
-# MPLEX_LIBS="$MPLEX_LIBS -lmplex2 -lm"
-# OLD_LIBS="$LIBS"
-# LIBS="$LIBS $MPLEX_LIBS"
-# AC_MSG_CHECKING([for valid mplex objects])
-# AC_TRY_RUN([
-##include <interact.hpp>
-##include <outputstrm.hpp>
-##include <multiplexor.hpp>
-#
-#int main (int argc, char *argv[])
-#{
-# class TestOutputStream : public OutputStream {
-# public:
-# TestOutputStream () : OutputStream () { }
-# void Write (uint8_t *a, unsigned int b) { }
-# void NextSegment () { }
-# off_t SegmentSize () { }
-# void Close () { }
-# int Open () { }
-# };
-# MultiplexJob *job = new MultiplexJob ();
-# vector<IBitStream *> inputs;
-# job->SetupInputStreams (inputs);
-# TestOutputStream *out = new TestOutputStream ();
-# Multiplexor *mux = new Multiplexor(*job, *out);
-# return 0;
-#}
-# ],[
-# HAVE_MPLEX="yes"
-# AC_SUBST(MPLEX_CFLAGS)
-# AC_SUBST(MPLEX_LIBS)
-# AC_MSG_RESULT(yes)
-# ], AC_MSG_RESULT(no))
-# #LIBS="$OLD_LIBS"
-# ])
-# #CPPFLAGS="$OLD_CPPFLAGS"
-# AC_LANG_C
-# ], HAVE_MPLEX="no")
-#AC_CHECK_LIB(mplex2, main, , AC_MSG_ERROR([*** libmplex2 not found (part of the mjpegtools package)!]))
+dnl ======================
+dnl Check for the ffmpeg library
+dnl ======================
+AC_CHECK_HEADER(ffmpeg/avformat.h, , AC_MSG_ERROR([*** ffmpeg (avformat) include files not found!]))
+AC_CHECK_HEADER(ffmpeg/avcodec.h, , AC_MSG_ERROR([*** ffmpeg (avcodec) include files not found!]))
+AC_CHECK_LIB(avformat, av_register_all, , AC_MSG_ERROR([*** ffmpeg (avformet) not found!]))
+AC_CHECK_LIB(avcodec, avcodec_decode_video, , AC_MSG_ERROR([*** ffmpeg (avcodec) not found!]))
AC_SUBST(CFLAGS)
AC_SUBST(CPPFLAGS)
@@ -131,7 +98,8 @@ AC_SUBST(LDFLAGS)
AC_OUTPUT(
Makefile
- src/Makefile
+ miavd/Makefile
+ miav/Makefile
tools/Makefile
etc/Makefile
pixmaps/Makefile