summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 20 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 82906fb..3c77551 100644
--- a/configure.in
+++ b/configure.in
@@ -9,10 +9,29 @@ AM_PROG_LIBTOOL
AM_CONFIG_HEADER(config.h)
AC_STDC_HEADERS
-CXXFLAGS="$CXXFLAGS -Wall -Werror"
+
+CXXFLAGS="$CXXFLAGS -I../lib"
+LDFLAGS="$LDFLAGS -L../lib"
AC_OUTPUT(lib/Makefile)
+AC_DEFINE_UNQUOTED(ETC, "$prefix/etc/miav", [The path to the config files])
+AC_DEFINE_UNQUOTED(PIXMAPS, "$prefix/share/pixmaps", [The path to the pixmap files])
+
+AC_ARG_WITH(debug, [ --with-debug Build with debugging (-g -Wall -Werror and -lefence)])
+if test x$with_debug != xno && test -z "$DEBUG"; then
+ CXXFLAGS="$CXXFLAGS -g -Wall -Werror"
+
+ dnl =====================
+ dnl Check for efence library
+ dnl =====================
+# AC_CHECK_LIB(efence, malloc, , AC_MSG_ERROR([*** The electric fence library (libefence.a) was not found!]))
+# LDFLAGS="$LDFLAGS -lefence"
+
+ dnl Make code aware of debug
+ AC_DEFINE([USE_DEBUG], [], [Is defined if the project is configured to compile with debugging])
+fi
+
AC_ARG_WITH(client, [ --without-client Build without client support])
if test x$with_client != xno && test -z "$CLIENT"; then
CLIENT_DIR=client