summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authordeva <deva>2005-04-05 11:22:05 +0000
committerdeva <deva>2005-04-05 11:22:05 +0000
commit55a7afdedc7cee2df9012f600dd51aff92ad1af3 (patch)
treedb6568a6aab7cfdec0d0afcb9bd7566939a4a318 /configure.in
parent6f03a23e7876516d3ba011d23acf454138432654 (diff)
Added validity checking on the conf parser.
Added error object to conf parser. Cleaned up the configure.in script
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in166
1 files changed, 24 insertions, 142 deletions
diff --git a/configure.in b/configure.in
index cb5514d..d53a1aa 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# Filnavn: configure.in
+# Filename: configure.in
AC_INIT(src/miav.cc)
AM_INIT_AUTOMAKE( miav, 0.1.1 )
@@ -12,142 +12,37 @@ AM_CXXFLAGS="-O2"
AC_STDC_HEADERS
AC_ARG_WITH(gui, [ --without-gui build without GUI support])
- if test x$with_gui != xno && test -z "$GUI"; then
-#dnl ====================
-#dnl Check for Qt library
-#dnl ====================
-#AC_ARG_WITH(qt, [ --with-qt build with Qt utils. (autodetected)],
-# [], with_qt=yes)
-#dnl no X means no Qt
-#test x$have_x != xyes && with_qt=no
-#
-#if test x$with_qt = xyes ; then
-# AC_PATH_QT(200, test -z "$qt_version" && qt_version=0
-# AC_DEFINE_UNQUOTED(HAVE_LIBQT, $qt_version, [Define if using 'Qt' libraries.]),
-# with_qt=no)
-#else
-# AC_MSG_RESULT([compilation of Qt utils disabled])
-#fi
-#
-#if test x$with_qt = xyes ; then
-# AC_LANG_SAVE
-# AC_LANG_CPLUSPLUS
-# save_CXXFLAGS=$CXXFLAGS
-# save_LIBS=$LIBS
-# CXXFLAGS="$CXXFLAGS $QT_CFLAGS $X_CFLAGS"
-# LIBS="$LIBS $QT_LIBS $X_LIBS $PTHREAD_LIBS"
-# AC_CACHE_CHECK([for multithreading support in Qt],
-# ac_cv_val_with_qt_multi,
-# [ AC_TRY_LINK([
-# #define QT_THREAD_SUPPORT
-# #include <qapplication.h> ],
-# [ qApp->wakeUpGuiThread(); ],
-# [ ac_cv_val_with_qt_multi=yes ],
-# [ ac_cv_val_with_qt_multi=no ])
-# ])
-# CXXFLAGS=$save_CXXFLAGS
-# LIBS=$save_LIBS
-#
-# if test x$ac_cv_val_with_qt_multi != xyes ; then
-# AC_MSG_WARN([
-#*** Your Qt installation does not support multi-threading!
-#*** Avifile will be compiled - however it might crash mysteriously
-#*** Instalation of threaded Qt library version (qt-mt) is recommended
-#*** When rebuilding Qt use configure option '-thread'.])
-# fi
-#
-# AC_MSG_CHECKING(Qt version for Avicap)
-# if test $qt_version -ge 220 ; then
-# AC_MSG_RESULT([yes])
-# else
-# AC_MSG_RESULT([no (needs Qt 2.2.0 or better)])
-# build_avicap=no
-# fi
-# AC_LANG_RESTORE
-#fi
-
+if test x$with_gui != xno && test -z "$GUI"; then
+ dnl =====================
+ dnl Check for QT library
+ dnl =====================
+ gw_CHECK_QT
+ CXXFLAGS="$CXXFLAGS $QT_CXXLAGS"
+ LDFLAGS="$LDFLAGS $QT_LDADD"
+
+ dnl =====================
+ dnl Check for SDL library
+ dnl =====================
+ SDL_VERSION=1.2.0
+ AM_PATH_SDL($SDL_VERSION,:,AC_MSG_ERROR([*** SDL version $SDL_VERSION not found!]))
+ CXXFLAGS="$CXXFLAGS $SDL_CFLAGS"
+ LDFLAGS="$LDFLAGS $SDL_LIBS"
+
+ dnl Make code aware of the gui
+ AC_DEFINE([USE_GUI], [], [Is defined if the project is configured to compile with gui])
+else
+ AC_MSG_WARN([*** Building without GUI support!])
+fi
dnl ======================
dnl Check for Jpeg library
dnl ======================
-AC_CHECK_HEADER(jpeglib.h, have_jpeglib=yes, have_jpeglib="no ")
-if test x$have_jpeglib = xyes; then
-dnl default action left - saving $LIBS is necessary
- save_LIBS=$LIBS
- AC_CHECK_LIB(jpeg, jpeg_start_compress, , have_jpeglib="no ")
- LIBS=$save_LIBS
-fi
-
-#dnl =====================
-#dnl Check for SDL library
-#dnl =====================
-#AC_ARG_WITH(sdl, [ --with-sdl build with SDL. (autodetected)],
-# [], with_sdl=yes)
-#
-#if test x$with_sdl != xyes; then
-# with_sdl="no (video rendering unavailable as requested!)"
-# AC_MSG_WARN([
-#*** there will be NO video rendering without SDL support!])
-#else
-# SDL_MIN_VERSION=1.0.0
-# save_CFLAGS=$CFLAGS
-# save_CPPFLAGS=$CPPFLAGS
-# save_LIBS=$LD_FLAGS
-# LIBS=
-# AM_PATH_SDL($SDL_MIN_VERSION,
-# AC_DEFINE(HAVE_LIBSDL, 1, [Define if using 'SDL' library (-lsdl).]),
-# with_sdl="no (*** no SDL => no video rendering! ***)"
-# AC_MSG_WARN([Could not find SDL >= $SDL_MIN_VERSION!]) )
-# CFLAGS=$save_CFLAGS
-# CXXFLAGS=$save_CPPFLAGS
-# LDFLAGS="$save_LIBS
-#fi
-
- dnl QT lib check macro (located in acinclude.m4)
- gw_CHECK_QT
- CXXFLAGS="$CXXFLAGS $QT_CXXLAGS"
- LDFLAGS="$LDFLAGS $QT_LDADD"
-
- dnl Check for SDL
- SDL_VERSION=1.2.0
- AM_PATH_SDL($SDL_VERSION,
- :,
- AC_MSG_ERROR([*** SDL version $SDL_VERSION not found!])
- )
- CXXFLAGS="$CXXFLAGS $SDL_CFLAGS"
- LDFLAGS="$LDFLAGS $SDL_LIBS"
-
- dnl Make code aware of the gui
- AC_DEFINE([USE_GUI], [], [Is defined if te project is configured to compile with gui])
- fi
-
-dnl =======================
-dnl Configure ffmpeg plugin
-dnl =======================
-#AM_PATH_FFMPEG
-
-#LD_FLAGS=$LD_FLAGS $LIBS
-
-# And now for the conditionals (for ffmpeg)
-#AM_CONDITIONAL(AMM_LINK_SHARED, test $lt_major_version -ge 1 -a $lt_minor_version -ge 4 -a $lt_micro_version -ge 3 )
-#AM_CONDITIONAL(AMM_FF_A52BIN, test x$enable_ffmpeg_a52bin = xyes)
-#AM_CONDITIONAL(AMM_FF_FAAD, test x$have_faad = xyes )
-#AM_CONDITIONAL(AMM_FF_ALPHAOPT, test x$enable_alphaopt = xyes)
-#AM_CONDITIONAL(AMM_FF_ARMOPT, test x$enable_armopt = xyes)
-#AM_CONDITIONAL(AMM_FF_MIPSOPT, test x$enable_mipsopt = xyes)
-#AM_CONDITIONAL(AMM_FF_MLIBOPT, test x$enable_mlibopt = xyes)
-#AM_CONDITIONAL(AMM_FF_PPCOPT, test x$enable_ppcopt = xyes)
-#AM_CONDITIONAL(AMM_FF_PS2OPT, test x$enable_ps2opt = xyes)
-#AM_CONDITIONAL(AMM_FF_SH4OPT, test x$enable_sh4opt = xyes)
-#AM_CONDITIONAL(AMM_FF_X86OPT, test x$enable_x86opt = xyes)
-#AM_CONDITIONAL(AMM_USE_OSS, test x$enable_oss = xyes)
-#AM_CONDITIONAL(AMM_USE_V4L, test x$enable_v4l = xyes )
-
+AC_CHECK_HEADER(jpeglib.h, , AC_MSG_ERROR([*** LibJpeg not found!]))
+AC_CHECK_LIB(jpeg, jpeg_start_compress, , AC_MSG_ERROR([*** LibJpeg not found!]))
AC_SUBST(CFLAGS)
AC_SUBST(CPPFLAGS)
AC_SUBST(CXXFLAGS)
-
AC_SUBST(LDFLAGS)
AC_OUTPUT(
@@ -155,16 +50,3 @@ AC_OUTPUT(
src/Makefile
tools/Makefile
pixmaps/Makefile)
-# ffmpeg/Makefile
-# ffmpeg/libavformat/Makefile
-# ffmpeg/libavcodec/Makefile
-# ffmpeg/libavcodec/alpha/Makefile
-# ffmpeg/libavcodec/armv4l/Makefile
-# ffmpeg/libavcodec/i386/Makefile
-# ffmpeg/libavcodec/liba52/Makefile
-# ffmpeg/libavcodec/libpostproc/Makefile
-# ffmpeg/libavcodec/mlib/Makefile
-# ffmpeg/libavcodec/ppc/Makefile
-# ffmpeg/libavcodec/ps2/Makefile
-# ffmpeg/libavcodec/sh4/Makefile
-# )