summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2014-06-24 08:23:00 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2014-06-24 08:23:00 +0200
commite6a1477dc0b8de4164cfbf470d0848bb97d41795 (patch)
treef5062b4ccc04ccad8db3be6f39762eb97e5210b2 /configure.in
parentad8cea4ad365658b6bee9ef5c247a042de9061cb (diff)
Modernise configure script
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in48
1 files changed, 0 insertions, 48 deletions
diff --git a/configure.in b/configure.in
deleted file mode 100644
index a70f61d..0000000
--- a/configure.in
+++ /dev/null
@@ -1,48 +0,0 @@
-# Filename: configure.in
-
-AC_INIT(src/audioin.cc)
-
-AM_INIT_AUTOMAKE( libaudioin, 0.12 )
-
-dnl ======================
-dnl Init pkg-config
-dnl ======================
-PKG_PROG_PKG_CONFIG(0.23)
-
-dnl ======================
-dnl Compile with debug options
-dnl ======================
-AC_ARG_WITH(debug,
- [ --with-debug build with debug support (default=no)],
- [],
- [with_debug=no])
-if test x$with_debug == xyes; then
- AC_MSG_WARN([*** Building with debug support!])
- AC_DEFINE_UNQUOTED(WITH_DEBUG, , [The project is configured to use debug output])
- CXXFLAGS="$CXXFLAGS -D_FORTIFY_SOURCE=2 -fstack-protector -Wall -Werror -g -O0"
-fi
-
-dnl ======================
-dnl Check for alsa library
-dnl ======================
-PKG_CHECK_MODULES(ALSA, alsa >= 1.0.23)
-
-AC_PROG_CXX
-
-AC_PROG_LIBTOOL
-AM_PROG_LIBTOOL
-
-AM_CONFIG_HEADER(config.h)
-AC_STDC_HEADERS
-
-AC_SUBST(CFLAGS)
-AC_SUBST(CPPFLAGS)
-AC_SUBST(CXXFLAGS)
-AC_SUBST(LDFLAGS)
-
-AC_OUTPUT(
- Makefile
- src/Makefile
- tools/Makefile
- audioin.pc)
-